pkgsrc/mail/thunderbird17/patches/patch-mk
ryoon affa333537 Import thunderbird17-17.0.10 as mail/thunderbird17.
Mozilla Thunderbird is a redesign of the Mozilla mail component. The
goal is to produce a cross platform stand alone mail application using
the XUL user interface language. This version uses the gtk2 toolkit.

This package tracks 24 ESR release branch.
2013-11-13 13:27:45 +00:00

30 lines
736 B
Text

$NetBSD: patch-mk,v 1.1 2013/11/13 13:27:45 ryoon Exp $
Treat DragonFly like FreeBSD.
--- mozilla/config/rules.mk.orig 2012-08-25 00:30:58.000000000 +0000
+++ mozilla/config/rules.mk
@@ -454,6 +454,12 @@ EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
endif
endif
+ifeq ($(OS_ARCH),DragonFly)
+ifdef IS_COMPONENT
+EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
+endif
+endif
+
ifeq ($(OS_ARCH),NetBSD)
ifneq (,$(filter arc cobalt hpcmips mipsco newsmips pmax sgimips,$(OS_TEST)))
ifeq ($(MODULE),layout)
@@ -463,6 +469,10 @@ endif
endif
endif
+ifeq ($(OS_ARCH),NetBSD)
+EXTRA_DSO_LDOPTS += -Wl,-rpath,${PREFIX}/lib/thunderbird
+endif
+
#
# HP-UXBeOS specific section: for COMPONENTS only, add -Bsymbolic flag
# which uses internal symbols first