a0431219da
* Added basic archive writing support. * Added a cpio archive module. * Added a zip archive module. * Added the beginnings of a cab archive module. * Added new API functions, which include: cxMkDir(), cxGets(), cxExtractFile(), cxExtractArchive(), cxMakePhysDirs(), cxApplyFsNodeInfo(), cxMakeFile(), cxGetArchiveFileCount() * Added functions for extracting individual files and full archives. * Added extraction notification callbacks. * Added pkg-config support. * Added gettext v0.11.3+ support. * Added an Italian translation. Thanks Domenico Andreoli! * Added a Dutch translation. Thanks Bert De Meyer! * Added support for some non-ustar tar formats. * Added a test program to display the file/directory tree inside of an archive. * Removed comprex.h. Applications should now include libcomprex/comprex.h. * Fixed the extraction code so permissions, timestamps, and ownerships are set on files and directories. * Fixed cxEof(). * Fixed the file and directory iterator. It should provide the correct results now. * Fixed a bug in the ar module where filenames weren't always read in correctly. * Fixed a bug in the tar module where filenames that start with '.' weren't processed correctly. * Fixed library linking problems with libbz2 and libz. * Fixed compiling errors when --prefix wasn't specified, and linking errors with libltdl.
28 lines
1.5 KiB
Text
28 lines
1.5 KiB
Text
$NetBSD: patch-ab,v 1.2 2005/08/08 09:00:00 adam Exp $
|
|
|
|
--- tests/Makefile.in.orig 2003-03-06 04:45:12.000000000 +0000
|
|
+++ tests/Makefile.in
|
|
@@ -233,19 +233,19 @@ clean-noinstPROGRAMS:
|
|
done
|
|
catarchive$(EXEEXT): $(catarchive_OBJECTS) $(catarchive_DEPENDENCIES)
|
|
@rm -f catarchive$(EXEEXT)
|
|
- $(LINK) $(catarchive_LDFLAGS) $(catarchive_OBJECTS) $(catarchive_LDADD) $(LIBS)
|
|
+ $(LINK) $(catarchive_LDFLAGS) $(catarchive_OBJECTS) $(catarchive_LDADD) $(LIBS) $(INTLLIBS)
|
|
catfile$(EXEEXT): $(catfile_OBJECTS) $(catfile_DEPENDENCIES)
|
|
@rm -f catfile$(EXEEXT)
|
|
- $(LINK) $(catfile_LDFLAGS) $(catfile_OBJECTS) $(catfile_LDADD) $(LIBS)
|
|
+ $(LINK) $(catfile_LDFLAGS) $(catfile_OBJECTS) $(catfile_LDADD) $(LIBS) $(INTLLIBS)
|
|
extractarchive$(EXEEXT): $(extractarchive_OBJECTS) $(extractarchive_DEPENDENCIES)
|
|
@rm -f extractarchive$(EXEEXT)
|
|
- $(LINK) $(extractarchive_LDFLAGS) $(extractarchive_OBJECTS) $(extractarchive_LDADD) $(LIBS)
|
|
+ $(LINK) $(extractarchive_LDFLAGS) $(extractarchive_OBJECTS) $(extractarchive_LDADD) $(LIBS) $(INTLLIBS)
|
|
makearchive$(EXEEXT): $(makearchive_OBJECTS) $(makearchive_DEPENDENCIES)
|
|
@rm -f makearchive$(EXEEXT)
|
|
$(LINK) $(makearchive_LDFLAGS) $(makearchive_OBJECTS) $(makearchive_LDADD) $(LIBS)
|
|
showtree$(EXEEXT): $(showtree_OBJECTS) $(showtree_DEPENDENCIES)
|
|
@rm -f showtree$(EXEEXT)
|
|
- $(LINK) $(showtree_LDFLAGS) $(showtree_OBJECTS) $(showtree_LDADD) $(LIBS)
|
|
+ $(LINK) $(showtree_LDFLAGS) $(showtree_OBJECTS) $(showtree_LDADD) $(LIBS) $(INTLLIBS)
|
|
|
|
mostlyclean-compile:
|
|
-rm -f *.$(OBJEXT) core *.core
|