Originally this was an attempt to upgrade version 5.0.0 to version 5.1-RELEASE or even 5.2-DEVELOPMENT, but it turns out that those versions require a GNAT Ada compiler based on gcc 4.7, which hasn't had its first release yet. This is mainly due to an change in the project management API, but using the 4.7 source files fail to compile due to the new SPARK restrictions. Therefore GPS must remain at 5.0.x until such time as GNAT-AUX is based on gcc 4.7. This is a bug fix release. The list of bug fixes is unknown, but it's confirmed the bug on the project dialog, library tab has been fixed and thus those patches are removed. The Makefile was updated to allow GPS users to take advantage of the numerous Python scripts, the Python console, and the python-GTK bindings. The option is present, but it has been removed from the option list because the pkgsrc version of Python cause GPS to core dump due to missing symbols in their dynamically-loaded libraries. Version 2.6 and version 2.7 were both tested, and fail in different ways. For comparison, the FreeBSD version of GPS builds and operates fine with Python 2.7, although at times similar "undefined symbol" messages appear it that error log. Once the issues with Python are fixed, this new "python" option in options.mk will be re-enabled.
15 lines
637 B
Text
15 lines
637 B
Text
$NetBSD: patch-al,v 1.1 2011/10/14 17:22:06 marino Exp $
|
|
|
|
--- gnatlib/src/nopython/gnatcoll-scripts-python.ads.orig 2010-10-14 12:15:05.000000000 +0200
|
|
+++ gnatlib/src/nopython/gnatcoll-scripts-python.ads 2011-10-09 05:03:58.000000000 +0200
|
|
@@ -31,7 +31,9 @@
|
|
|
|
procedure Register_Python_Scripting
|
|
(Repo : Scripts.Scripts_Repository;
|
|
- Module : String);
|
|
+ Module : String;
|
|
+ Program_Name : String := "python";
|
|
+ Python_Home : String := "");
|
|
procedure Unregister_Python_Scripting
|
|
(Repo : Scripts.Scripts_Repository);
|
|
-- Does nothing, since python was not compiled in.
|