44 lines
1.1 KiB
Text
44 lines
1.1 KiB
Text
$NetBSD: patch-aa,v 1.3 2005/11/11 16:49:32 joerg Exp $
|
|
|
|
--- Makefile.orig 2000-03-28 20:23:58.000000000 +0000
|
|
+++ Makefile
|
|
@@ -18,23 +18,29 @@ LDFLAGS =
|
|
|
|
########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
|
|
|
|
+OS= $(shell uname -s)
|
|
+
|
|
+ifeq ($(OS), Linux)
|
|
# For Linux (and maybe others), use these:
|
|
CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
|
|
DEPS = $(OBJS) makebplay
|
|
LIBS = -lncurses -lm
|
|
COPY_A = -a
|
|
-
|
|
+else
|
|
+ifeq (,$(filter-out NetBSD DragonFly,$(OS)))
|
|
# For FreeBSD (and maybe others), use these:
|
|
-#CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
|
|
-#DEPS = $(OBJS) makebplay
|
|
-#LIBS = -lncurses -lm
|
|
-#COPY_A = -p
|
|
-
|
|
+CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DOLD_CURSES
|
|
+DEPS = $(OBJS) makebplay
|
|
+LIBS = -lcurses -lm
|
|
+COPY_A = -p
|
|
+else
|
|
# For IRIX (and maybe others), use these:
|
|
-#CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DSWAP_ENDIAN -DOLD_CURSES
|
|
-#DEPS = $(OBJS)
|
|
-#LIBS = -lcurses -lm
|
|
-#COPY_A = -a
|
|
+CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DSWAP_ENDIAN -DOLD_CURSES
|
|
+DEPS = $(OBJS)
|
|
+LIBS = -lcurses -lm
|
|
+COPY_A = -a
|
|
+endif
|
|
+endif
|
|
|
|
##########
|
|
|