pkgsrc/databases/mysql57-client/patches/patch-include_CMakeLists.txt
adam 7cb1f0a9d9 MySQL is a SQL (Structured Query Language) database server. SQL is the most
popular database language in the world. MySQL is a client-server implementation
that consists of a server daemon `mysqld' and many different client
programs/libraries.

The main goals of MySQL are speed and robustness.

The base upon which MySQL is built is a set of routines that have been used in
a highly demanding production environment for many years.  While MySQL is still
in development it already offers a rich and highly useful function set.
2016-09-16 06:49:11 +00:00

21 lines
512 B
Text

$NetBSD: patch-include_CMakeLists.txt,v 1.1 2016/09/16 06:49:11 adam Exp $
Only mysql-client installs includes.
--- include/CMakeLists.txt.orig 2016-03-28 18:06:12.000000000 +0000
+++ include/CMakeLists.txt
@@ -69,6 +69,7 @@ SET(HEADERS
${HEADERS_GEN_CONFIGURE}
)
+IF(WITHOUT_SERVER)
INSTALL(FILES
../libbinlogevents/export/binary_log_types.h
DESTINATION ${INSTALL_INCLUDEDIR}
@@ -78,5 +79,5 @@ INSTALL(DIRECTORY mysql/ DESTINATION ${I
PATTERN "*.h"
PATTERN "psi_abi*" EXCLUDE
)
-
+ENDIF()