a62b3e67a6
With apologies to Al I wouldn't know where to start with a summary of the changes between 2.1 and 2.2.1 - there are just too many. A couple of hopefully static URLS that contain useful information are http://www.kde.org/announcements/changelog2_1to2_2.html http://www.kde.org/announcements/changelog2_2to2_2_1.html Support for a.out for kde{libs,base} added by me. The libtool/a.out combination doesn't like the linking of modules into binaries. A better way of doing this will appear in future versions of KDE/pkgsrc.
33 lines
1 KiB
Text
33 lines
1 KiB
Text
$NetBSD: patch-bl,v 1.1 2001/10/15 22:46:02 skrll Exp $
|
|
|
|
--- khotkeys/khotkeys/Makefile.am.orig Sat May 19 02:07:18 2001
|
|
+++ khotkeys/khotkeys/Makefile.am
|
|
@@ -2,13 +2,17 @@
|
|
|
|
bin_PROGRAMS = khotkeys
|
|
-lib_LTLIBRARIES = khotkeys.la
|
|
+lib_LTLIBRARIES = libkhotkeys_main.la khotkeys.la
|
|
|
|
-khotkeys_la_SOURCES = khkglobalaccel.cpp khotkeys.cpp main.cpp \
|
|
+libkhotkeys_main_la_SOURCES = khkglobalaccel.cpp khotkeys.cpp main.cpp \
|
|
khotkeys.skel
|
|
-khotkeys_la_LIBADD = ../shared/libshared.la -lksycoca
|
|
+libkhotkeys_main_la_LIBADD = ../shared/libshared.la -lksycoca
|
|
+libkhotkeys_main_la_LDFLAGS = $(all_libraries)
|
|
+
|
|
+khotkeys_la_SOURCES = khotkeys_main.cpp
|
|
+khotkeys_la_LIBADD = libkhotkeys_main.la
|
|
khotkeys_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
|
|
-khotkeys_SOURCES = dummy.cpp
|
|
-khotkeys_LDADD = khotkeys.la
|
|
+khotkeys_SOURCES = khotkeys_main.cpp
|
|
+khotkeys_LDADD = libkhotkeys_main.la
|
|
khotkeys_LDFLAGS = $(all_libraries) $(KDE_RPATH)
|
|
|
|
@@ -21,5 +25,2 @@
|
|
|
|
METASOURCES = AUTO
|
|
-
|
|
-dummy.cpp:
|
|
- echo > dummy.cpp
|