pkgsrc/x11/kdebase2/patches/patch-bs
skrll a100f5d455 Update to KDE 2.2.2
Closes pkg/14728 from Mark Davies <mark@mcs.vuw.ac.nz>. Changes from him
with updates from myself.

From www.kde.org... The principal improvements over KDE 2.2.1, release two
months ago, include:

o security-related
	- SSL certificate loading
	- symlink vulnerability in .wmrc access by KDM introduced in 2.2
	- security problem with eFax (used by klprfax)
	- potential problem in PAM invocation by KDM
	- potential harmful side-effect of failed KDM session starts

o new features
	- added support for CodeWeavers' CrossOver plug-in (provides support
	  for QuickTime, etc.)
	- added support for the wheelmouse for scrolling through the
	  KGhostview PS/PDF viewer component
	- ability to search for multiple patterns at a time in the file
	  search dialog
	- debugging multi-threaded applications with KDevelop

o improvements/fixes
	- handling of HTTP links that redirect to FTP
	- POST using SSL through a proxy and sending headers through proxies
	- saving of recently-selected files in the file dialog
	- handling of non-ASCII characters over SMB
	- toolbar button captions with certain styles
	- selecting items with the mouse in Konqueror
	- sorting in Konqueror's textview
	- saving current settings as a theme in the theme manager
	- crashes in KMail with certain mails
	- crash on invoking the KDM chooser
	- non-Latin languages with KDevelop

performance
	- icon loading optimized
	- file dialog speedups
	- stop spinning SMB client processes
	- handling of large files in Kate
2001-12-03 15:37:14 +00:00

22 lines
851 B
Text

$NetBSD: patch-bs,v 1.2 2001/12/03 15:37:19 skrll Exp $
--- kicker/applets/launcher/Makefile.in.orig Sat Nov 10 07:58:25 2001
+++ kicker/applets/launcher/Makefile.in
@@ -288,7 +288,7 @@
EXTRA_DIST = $(lnk_DATA)
libquicklauncher_la_LDFLAGS = $(all_libraries) -version-info 1:0:0 -module
-libquicklauncher_la_LIBADD = ../../kicker.la $(LIB_KSYCOCA) $(LIB_KDEUI)
+libquicklauncher_la_LIBADD = ../../libkicker.la $(LIB_KSYCOCA) $(LIB_KDEUI)
mkinstalldirs = $(SHELL) $(top_srcdir)/admin/mkinstalldirs
CONFIG_HEADER = ../../../config.h
CONFIG_CLEAN_FILES =
@@ -301,7 +301,7 @@
LIBS = @LIBS@
X_CFLAGS = @X_CFLAGS@
X_LIBS = @X_LIBS@
-libquicklauncher_la_DEPENDENCIES = ../../kicker.la
+libquicklauncher_la_DEPENDENCIES = ../../libkicker.la
#>- libquicklauncher_la_OBJECTS = quicklauncher.lo quickbutton.lo \
#>- quickaddappsmenu.lo
#>+ 6