XULRunner is a runtime environment for applications using the XML User Interface Language, XUL. It is the successor of the "Gecko" runtime environment.
24 lines
1.3 KiB
Text
24 lines
1.3 KiB
Text
$NetBSD: patch-ao,v 1.1.1.1 2009/08/05 02:59:48 tnn Exp $
|
|
|
|
--- toolkit/mozapps/installer/packager.mk.orig 2009-06-29 18:15:27.000000000 +0200
|
|
+++ toolkit/mozapps/installer/packager.mk
|
|
@@ -449,8 +449,8 @@ endif
|
|
(cd $(DIST)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(installdir) && tar -xf -)
|
|
$(NSINSTALL) -D $(DESTDIR)$(bindir)
|
|
- $(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
|
|
- ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)
|
|
+ $(RM) -f $(DESTDIR)$(bindir)/$(MOZILLA_PKG_NAME)
|
|
+ ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)/$(MOZILLA_PKG_NAME)
|
|
ifdef INSTALL_SDK # Here comes the hard part
|
|
# include directory is stable (dist/sdk/include) and unstable (dist/include)
|
|
$(NSINSTALL) -D $(DESTDIR)$(includedir)/stable
|
|
@@ -458,7 +458,7 @@ ifdef INSTALL_SDK # Here comes the hard
|
|
(cd $(DIST)/sdk/include && tar $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir)/stable && tar -xf -)
|
|
# The dist/include has module subdirectories that we need to flatten
|
|
- find $(DIST)/include -xtype f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
|
|
+ find $(DIST)/include -type f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
|
|
# IDL directory is stable (dist/sdk/idl) and unstable (dist/idl)
|
|
$(NSINSTALL) -D $(DESTDIR)$(idldir)/stable
|
|
$(NSINSTALL) -D $(DESTDIR)$(idldir)/unstable
|