pkgsrc/lang/nhc98/patches/patch-aa
dholland a5ef90ff9d Update to 1.22.
Does not include all the changes in PR 45318, some of which need
further investigation.

pkgsrc changes:
   - update MASTER_SITES and HOMEPAGE
   - remove LP64 restriction (LP64 platforms are supported using -m32)
   - add destdir support (provided by upstream) and lift BROKEN
   - remove some pkglint
   - mark MAKE_JOBS_SAFE=no
   - add readline.bl3.mk
   - patch-ag was applied upstream
   - remove patch-ah and handle the issue involved a cleaner way

Caution: so far the LP64 build does not actually work yet, -m32
notwithstanding; it dies with
   PreludeList.init: empty list
   PreludeList.init: empty list
   PreludeList.init: empty list
i386 works though.

Upstream changes:

nhc98 1.22 (2010-07-09) features

    There are no new features, just an update to the current set of
    libraries as of the release date.

nhc98 1.20 (2007-11-22) features

    New: Pattern guards are supported.
    New: More hierarchical libraries have been added to the base package.
    Bugfix: Now builds on 64-bit machines (in 32-bit mode)
    Bugfix: Newer version of hmake (3.13)
    Bugfix: The evil mangler is now less evil (and more robust)
    Bugfix: Add a workaround for the hi-membug that caused build
            failures on many recent Linux platforms.
    Bugfix: Lexical error on varid _2a is fixed.
    Bugfix: Renaming bug in newtype A a = A a.
    Bugfix: hp2graph problem with x-axis resolution in interval (-i) sampling.
    Bugfix: hp2graph end-of-file parsing bug.
    New: The runtime system code is now documented using funnelweb.
2013-10-25 06:25:18 +00:00

52 lines
2.2 KiB
Text

$NetBSD: patch-aa,v 1.9 2013/10/25 06:25:18 dholland Exp $
- always set the compiler to "gcc" for pkgsrc
- honor pkgsrc LDFLAGS
--- configure.orig 2010-07-09 12:41:23.000000000 +0000
+++ configure
@@ -65,8 +65,8 @@ chmod +x script/harch || exit 1
MACHINE=`script/harch`
case $MACHINE in
- powerpc-Darwin[56]) CCC=${CC-cc} ;;
- *) CCC=${CC-gcc} ; ;;
+ powerpc-Darwin*) CCC=gcc;;
+ *) CCC=gcc;;
esac
STRIP=${STRIP}
@@ -482,16 +482,16 @@ main() {
void test (void) { mvaddstr(1,2,"hello world"); }
int main (void) { test(); }
!!!
- if $CCC $COPTS -m32 -o curses curses.c >/dev/null 2>/dev/null
+ if $CCC $COPTS $LDFLAGS -m32 -o curses curses.c >/dev/null 2>/dev/null
then CURSES=""
else
- if $CCC $COPTS -m32 -o curses curses.c -lncurses >/dev/null 2>/dev/null
+ if $CCC $COPTS $LDFLAGS -m32 -o curses curses.c -lncurses >/dev/null 2>/dev/null
then CURSES="-lncurses"
else
- if $CCC $COPTS -m32 -o curses curses.c -lcurses >/dev/null 2>/dev/null
+ if $CCC $COPTS $LDFLAGS -m32 -o curses curses.c -lcurses >/dev/null 2>/dev/null
then CURSES="-lcurses"
else
- if $CCC $COPTS -m32 -o curses curses.c -lcurses -ltermcap >/dev/null 2>/dev/null
+ if $CCC $COPTS $LDFLAGS -m32 -o curses curses.c -lcurses -ltermcap >/dev/null 2>/dev/null
then CURSES="-lcurses -ltermcap"
else CURSES="-ltermcap -lcurses" # don't know a good default?
fi
@@ -508,10 +508,10 @@ int main (void) { test(); }
echo -n "Testing for the readline library: "
echo 'main(){readline();}' >rd.c
- if ${CCC} $COPTS -m32 -o rd.out rd.c -lreadline >/dev/null 2>&1
+ if ${CCC} $COPTS $LDFLAGS -m32 -o rd.out rd.c -lreadline >/dev/null 2>&1
then echo ' -lreadline (detected)'
READLINE="-DUSE_READLINE=1 -lreadline"
- else if ${CCC} $COPTS -m32 -o rd.out rd.c -lreadline $CURSES >/dev/null 2>&1
+ else if ${CCC} $COPTS $LDFLAGS -m32 -o rd.out rd.c -lreadline $CURSES >/dev/null 2>&1
then echo " -lreadline $CURSES (detected)"
READLINE="-DUSE_READLINE=1 -lreadline $CURSES"
else echo ' no (detected)'