pkgsrc/print/cups/patches/patch-ag
jlam 4341c29296 Update print/cups to 1.1.20. Changes from version 1.1.19nb3 include:
Bug fixes:
	- The HTTP code did not use a case-insensitive
	  comparison when checking for the Basic authentication
	  method (STR #407)
	- The cupsaddsmb program didn't export the new CUPS
	  driver for Windows properly (STR #390)
	- The default landscape orientation was not the same as
	  that defined in the PPD file (STR #397)
	- The pdftops filter incorrectly auto-rotated pages when
	  the user already had specified the proper orientation
	  (STR #207)
	- The scheduler did not reset the group list when
	  running CGI and filter processes (STR #185)

Enhancements:
	- Updated the pdftops filter to use the annotation flags
	  instead of the subtype to determine whether to print
	  an annotation (STR #425)
	- The pdftops filter no longer needs to create temporary
	  files with tmpnam (STR #406)
	- The scheduler now waits up to 60 seconds before
	  restarting to allow active jobs to complete printing
	  and pending requests to be processed (STR #226)
	- Added new cupsDoAuthentication(), cupsGetFd(),
	  cupsGetFile(), cupsPutFd(), and cupsPutFile() functions
	  to the CUPS API (STR #112)
	- The PDF filter always scaled and offset pages; this
	  caused problems under MacOS X, so now the "fitplot"
	  option controls whether PDF files are scaled to fit
	  within the printable area of the page (STR #250)
	- Updated the pdftops filter to be based upon Xpdf
	  2.02pl1 (STR #191)
2004-01-10 03:32:09 +00:00

23 lines
585 B
Text

$NetBSD: patch-ag,v 1.16 2004/01/10 03:32:09 jlam Exp $
--- filter/Makefile.orig Mon Nov 17 17:04:53 2003
+++ filter/Makefile
@@ -46,7 +46,7 @@ OBJS = $(HPGLOBJS) $(IMAGEOBJS) $(FORMOB
# Make all targets...
#
-all: $(TARGETS) libcupsimage.a
+all: $(TARGETS) $(LIBCUPSIMAGE) libcupsimage.a
#
@@ -88,8 +88,8 @@ install: all installhdrs
fi
-if test $(LIBCUPSIMAGE) != "libcupsimage.a"; then \
$(INSTALL_LIB) libcupsimage.a $(LIBDIR); \
+ $(RANLIB) $(LIBDIR)/libcupsimage.a; \
fi
- $(RANLIB) $(LIBDIR)/libcupsimage.a
installhdrs:
$(INSTALL_DIR) $(INCLUDEDIR)/cups