2761b7f37c
ALD is an Assembly Language Debugger written by Patrick Alken. It's released under the GPL and has a familiar feel to it if you're used to GDB. Primary features include stepping, tracing, disassembly, a nice curses-based display, breakpoints, temporary breakpoints, and some library abstractions that people can use in their own software. This package is x86 only at the moment. Modified slightly by myself to conform to pkgsrc standards.
17 lines
458 B
Text
17 lines
458 B
Text
$NetBSD: patch-ac,v 1.1.1.1 2002/04/22 11:51:50 agc Exp $
|
|
|
|
--- ./libDebug/arch/ix86/source/Makefile.in.orig Wed Apr 17 08:34:00 2002
|
|
+++ ./libDebug/arch/ix86/source/Makefile.in
|
|
@@ -11,8 +11,11 @@
|
|
|
|
DEPENDFILE = .depend
|
|
|
|
+# below used to be:
|
|
+# @os_makefile_frag@ \ instead of bsd-x86 thingy
|
|
+
|
|
OBJECTS = \
|
|
- @os_makefile_frag@ \
|
|
+ $(OBJDIR)/bsd-x86.o \
|
|
$(OBJDIR)/sub-x86.o \
|
|
$(OBJDIR)/trace-x86.o
|
|
|