ce5b372b8c
=== Transmission 2.92 (2016/03/06) === [http://trac.transmissionbt.com/query?milestone=2.92&group=component&order=severity All tickets closed by this release] ==== Mac Client ==== * Build OSX.KeRanger.A ransomware removal into the app === Transmission 2.91 (2016/03/06) === [http://trac.transmissionbt.com/query?milestone=2.91&group=component&order=severity All tickets closed by this release] ==== All Platforms ==== * Fix Makefile.am to include Windows patches into source archive * Fix miniupnpc script to handle spaces and other special chars in paths ==== Mac Client ==== * Prevent crash during group rules removal in some cases * Fix failure to remove seeding completion notifications from notification center * Show main window and scroll to torrent on notification click * Fix issue on Yosemite where peers view didn't occupy all the available space when web seed view was hidden ==== Qt Client ==== * Fix existing running instance detection and torrents delegation when using DBus ==== Daemon ==== * Fix building on Windows x86 * Add `--blocklist-update` argument description to transmission-remote man page * Use `-rad` as short form of `--remove-and-delete` option in transmission-remote === Transmission 2.90 (2016/02/28) === [http://trac.transmissionbt.com/query?milestone=2.90&group=component&order=severity All tickets closed by this release] ==== All Platforms ==== * Fix renaming torrent files with common prefix * Fix some more thread safety bugs in the tr_list datatype * Fix infinite loop when removing torrent data * Add support for CyaSSL/WolfSSL and PolarSSL cryptographic backends; bump OpenSSL minimum to v0.9.7 * Initial CMake build system support * Many improvements to support Windows builds with MSVS and MinGW; drop XP/2003 support, only Vista and up now * Allow building against system UTP and DHT libraries * Fix several memory leaks and buffer overflows * Support miniupnpc API v14 * Fix "prefetch-enabled" value type in settings.json (boolean instead of integer) * Fix some issues discovered by static analysis (cppcheck, coverity) * Fix invalid JSON encoding for non-printable characters * Fix multi-threaded locale use when encoding/decoding JSON data * Fix encrypted communication with libevent 2.1+ * Prevent completed pieces modification by webseeds * Require absolute paths in RPC requests * Fix and unify torrent origin display in GTK+, Qt and web clients * Fix crash on session shutdown (evdns_getaddrinfo_cancel) * Retry if RPC server fails to bind to specified address * Improve error checking on metadata retrieval * Improve UTF-8 validity checking (merge changes from LLVM) * Don't build transmission-cli by default (it's long deprecated) ==== Mac Client ==== * UI fixes for OS X 10.9+ * Trim potential URIs from clipboard * Allow downloading files from http servers (not https) on OS X 10.11+ * Change Sparkle Update URL to use HTTPS instead of HTTP (addresses Sparkle vulnerability) * Fix global options popover layout * Fix building with Xcode 7+ * Drop OS X 10.6 support ==== GTK+ Client ==== * Fix overshoot and undershoot indicators display with GTK+ 3.16+ in main window * Don't require DISPLAY if started with `--version` argument ==== Qt Client ==== * Improve performance in Torrent Properties dialog for torrents with lots of files * Prevent entering file renaming mode with mouse double-click * Add context menu on files tab of Torrent Properties dialog resembling that of Mac client * Remove torrent file from watch directory even if "show options dialog" is not set * Use theme-provided icons in system tray and About dialog * Fix initial watch directory scan * Improve filter bar look and feel; lots of other small visual fixes; RTL layout fixes * Show message to the user when duplicate torrent is being added * Improve magnets handling in main window * Display notifications via tray icon if D-Bus is not available * Show notice on top of filtered torrents list; clear whole filter on notice double-click * Add proper compiler flags to indicate C++11 use * Fix translation files loading * Add Chinese (China), German, Indonesian, Italian (Italy), Korean, Polish (Poland), Ukrainian translations; update existing translations ==== Daemon ==== * Run as service on Windows when in background mode * Rework directory watching, add support for native mechanisms on BSD/Darwin (kqueue) and Windows (ReadDirectoryChanges) * Don't make assumptions of remote path validity in transmission-remote ==== Web Client ==== * Content Security Policy enhancements * Enable "resume now" for queued torrents * Mark appropriate fields in preferences dialog as HTML5 number fields * Update to jQuery 1.11.2, jQueryUI 1.11.4; use jQueryUI menus instead of custom ones
29 lines
877 B
INI
29 lines
877 B
INI
$NetBSD: patch-qt_qtr.pro,v 1.4 2016/04/15 09:28:40 wiz Exp $
|
|
|
|
--- qt/qtr.pro.orig 2015-12-29 00:47:32.464150631 +0000
|
|
+++ qt/qtr.pro
|
|
@@ -8,7 +8,8 @@ target.path = /bin
|
|
INSTALLS += target
|
|
|
|
unix: INSTALLS += man
|
|
-man.path = /share/man/man1/
|
|
+man.path = /man/man1/
|
|
+
|
|
man.files = transmission-qt.1
|
|
|
|
CONFIG += qt thread debug link_pkgconfig c++11 warn_on
|
|
@@ -28,12 +29,14 @@ include(config.pri)
|
|
|
|
INCLUDEPATH = $${EVENT_TOP}/include $${INCLUDEPATH}
|
|
INCLUDEPATH += $${TRANSMISSION_TOP}
|
|
+INCLUDEPATH += $${OPENSSL_CFLAGS}
|
|
LIBS += $${TRANSMISSION_TOP}/libtransmission/libtransmission.a
|
|
LIBS += $${LIBUTP_LIBS}
|
|
LIBS += $${DHT_LIBS}
|
|
LIBS += $${LIBB64_LIBS}
|
|
LIBS += $${LIBUPNP_LIBS}
|
|
LIBS += $${LIBNATPMP_LIBS}
|
|
+LIBS += $${OPENSSL_LIBS}
|
|
unix: LIBS += -L$${EVENT_TOP}/lib -lz -lrt
|
|
win32:LIBS += -levent-2.0 -lws2_32 -lintl
|
|
win32:LIBS += -lidn -liconv -lwldap32 -liphlpapi
|