544cf480ee
notable changes: OpenSSL 1.1.0 is now supported, and c-ares has been updated While touching the package anyhow, it has been taught to pass down hardening flags, so that the various PKGSRC_USE_ flags now have effect.
19 lines
786 B
Text
19 lines
786 B
Text
$NetBSD: patch-xymonproxy_Makefile,v 1.1 2017/09/28 10:40:35 spz Exp $
|
|
|
|
allow hardening
|
|
|
|
--- xymonproxy/Makefile.orig 2012-11-14 11:29:54.000000000 +0000
|
|
+++ xymonproxy/Makefile
|
|
@@ -15,10 +15,10 @@ MSGCGIOBJS = xymoncgimsg.o
|
|
all: $(PROGRAMS)
|
|
|
|
xymonproxy: $(PROXYOBJS) $(XYMONCOMMLIB) $(XYMONTIMELIB) $(XYMONLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(PROXYOBJS) $(XYMONCOMMLIBS) $(XYMONTIMELIBS) $(XYMONLIBS)
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(PROXYOBJS) $(XYMONCOMMLIBS) $(XYMONTIMELIBS) $(XYMONLIBS)
|
|
|
|
xymoncgimsg.cgi: $(MSGCGIOBJS) $(XYMONCOMMLIB) $(XYMONLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(MSGCGIOBJS) $(XYMONCOMMLIBS) $(XYMONLIBS)
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(MSGCGIOBJS) $(XYMONCOMMLIBS) $(XYMONLIBS)
|
|
|
|
################################################
|
|
# Default compilation rules
|