6d8afaf59c
This release fixes zillions of bugs (most notably, game saving/loading now works). Also included is PNG support. There are too many little changes to note, so see the ChangeLog for details.
22 lines
1 KiB
Text
22 lines
1 KiB
Text
$NetBSD: patch-ae,v 1.2 2004/08/25 20:26:18 snj Exp $
|
|
|
|
--- ruamoko/game/Makefile.am.orig 2004-02-02 22:00:16.000000000 -0800
|
|
+++ ruamoko/game/Makefile.am 2004-08-24 15:25:10.000000000 -0700
|
|
@@ -9,7 +9,7 @@ QFCC_DEP=$(top_builddir)/tools/qfcc/sour
|
|
QFCC=$(QFCC_DEP)
|
|
QCFLAGS=-qq -g -Werror
|
|
QCPPFLAGS=-I. -I$(srcdir) -I$(top_builddir)/ruamoko/include -I$(top_srcdir)/ruamoko/include
|
|
-GZIP=if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
|
|
+XGZIP=if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
|
|
if HAVE_ZLIB
|
|
GZ=.gz
|
|
else
|
|
@@ -38,7 +38,7 @@ game_obj=$(addsuffix .qfo,$(basename $(g
|
|
|
|
game.dat$(GZ): $(game_obj) ../lib/libr.a ../lib/libqw.a
|
|
$(QFCC) $(QCFLAGS) -p $(STRIP) -o game.dat $(game_obj) ../lib/libqw.a ../lib/libr.a
|
|
- $(GZIP)
|
|
+ $(XGZIP)
|
|
|
|
EXTRA_DIST= $(game_src) Axe.h GameEntity.h tempent.h Weapon.h World.h
|
|
CLEANFILES= *.dat *.sym *.gz *.qfo
|