314b24f382
as openldap1 for those who want to follow the 1.2.x release branch.
20 lines
704 B
Text
20 lines
704 B
Text
$NetBSD: patch-ab,v 1.1.1.1 2001/10/25 18:38:13 kleink Exp $
|
|
|
|
--- build/lib-shared.mk.orig Fri Jul 23 17:31:32 1999
|
|
+++ build/lib-shared.mk Fri Sep 10 12:19:58 1999
|
|
@@ -16,9 +16,11 @@
|
|
|
|
$(LIBRARY): version.lo
|
|
$(LTLIBLINK) -rpath $(libdir) -o $@ $(OBJS) version.lo
|
|
- $(RM) ../$@; \
|
|
- (d=`$(PWD)` ; $(LN_S) `$(BASENAME) $$d`/$@ ../$@)
|
|
- $(RM) ../`$(BASENAME) $@ .la`.a; \
|
|
- (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.a; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t)
|
|
+ @$(RM) ../$@
|
|
+ @for ext in a so so.1.0; do \
|
|
+ $(RM) ../`$(BASENAME) $@ .la`.$$ext; \
|
|
+ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.$$ext; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t); \
|
|
+ done
|
|
+
|
|
|
|
Makefile: $(top_srcdir)/build/lib-shared.mk
|