a71a3ab1d1
Patch provided by Jason White in PR 38473. Changes for 1.4.1: * Fixed a shape bug which caused it to flicker. * Fixed an icon file parsing bug. Changes for 1.4.0: * Imlib2 support: FbDesk can now load the following formats: xpm, png, jpg, jfi, jfif, pnm, ppm, pgm, pbm, pam, tga, gif and bmp. * Added new resource: fbdesk.textBackground: <color> * Added new resource: fbdesk.lockPositions: <bool> This will lock the position of the icons (also available in the menu) * Fixed gcc-4.1 compile problems (Thanks Andreas Bierfer andreas.bierfert at lowlatency.de ) Changes for 1.2.2: * Fixed --enable/disable-xpm configure option (Thanks Mathias Gumz) configure.in
9 lines
215 B
Text
9 lines
215 B
Text
$NetBSD: patch-ab,v 1.2 2008/05/10 16:19:16 obache Exp $
|
|
|
|
--- src/FbTk/FbPixmap.cc.orig 2006-03-25 11:47:10.000000000 +0000
|
|
+++ src/FbTk/FbPixmap.cc
|
|
@@ -23,2 +23,4 @@
|
|
|
|
+#include <stdio.h>
|
|
+
|
|
#include "FbPixmap.hh"
|