23 lines
639 B
Text
23 lines
639 B
Text
$NetBSD: patch-aj,v 1.1 2002/09/15 06:51:38 kim Exp $
|
|
|
|
Detect getutent correctly on NetBSD with utmpx.
|
|
|
|
--- configure.in.orig Sat Sep 14 23:22:33 2002
|
|
+++ configure.in Sat Sep 14 23:37:06 2002
|
|
@@ -798,9 +798,15 @@
|
|
AC_TRY_LINK([
|
|
#include <time.h> /* to get time_t on SCO */
|
|
#include <sys/types.h>
|
|
-#if defined(SVR4) && !defined(DGUX)
|
|
+#include <sys/param.h>
|
|
+#if (defined(SVR4) && !defined(DGUX)) \
|
|
+ || (defined(__NetBSD_Version__) && (__NetBSD_Version__ >= 106050000))
|
|
#include <utmpx.h>
|
|
#define utmp utmpx
|
|
+# ifdef __NetBSD__
|
|
+# define pututline pututxline
|
|
+# define getutent getutxent
|
|
+# endif
|
|
#else
|
|
#include <utmp.h>
|
|
#endif
|