pkgsrc/print/teTeX3-bin/patches/patch-ax
tonnerre e9a441e100 If mkdtemp is not defined, define our own version and deploy it. Also, don't
just add mkdtemp to configure.in but also make sure that it is heard.
PKGREVISION++.
2008-08-24 20:35:37 +00:00

112 lines
3.1 KiB
Text

$NetBSD: patch-ax,v 1.1 2008/08/24 20:35:37 tonnerre Exp $
--- /dev/null 2008-08-24 22:23:22.000000000 +0200
+++ texk/dviljk/mkdtemp.c 2008-08-24 22:23:18.000000000 +0200
@@ -0,0 +1,107 @@
+/*
+ * Copyright (c) 1987, 1993
+ * The Regents of the University of California. All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#include <c-auto.h>
+#ifdef KPATHSEA
+#include <kpathsea/config.h>
+#include <kpathsea/c-std.h>
+#include <kpathsea/c-limits.h>
+#include <kpathsea/magstep.h>
+#include <kpathsea/proginit.h>
+#include <kpathsea/progname.h>
+#include <kpathsea/tex-glyph.h>
+#include <kpathsea/tex-hush.h>
+#include <kpathsea/tex-make.h>
+#include <kpathsea/c-vararg.h>
+#else
+#include <string.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <unistd.h>
+#ifdef unix
+#include <limits.h>
+#endif
+#endif /* KPATHSEA */
+
+#include <signal.h>
+#include <ctype.h>
+#ifdef vms
+#include <file.h>
+#else
+# ifndef __riscos
+# include <fcntl.h>
+# endif
+#endif
+#ifdef MSC5
+#include <dos.h> /* only for binaryopen on device */
+#endif
+
+#ifndef HAVE_MKDTEMP
+
+char *
+mkdtemp(path)
+ char *path;
+{
+ char *tmppath;
+
+ assert(path != NULL);
+
+ tmppath = malloc(strlen(path));
+ assert(tmppath);
+
+ for (;;)
+ {
+ /* Reset string */
+ strcpy(tmppath, path);
+
+ if (!mktemp(tmppath))
+ {
+ free(tmppath);
+ return NULL;
+ }
+
+ if (!mkdir(tmppath, 0700))
+ {
+ /* Write back to user buffer. */
+ strcpy(path, tmppath);
+ free(tmppath);
+ return path;
+ }
+
+ if (errno != EEXIST)
+ {
+ free(tmppath);
+ return NULL;
+ }
+ }
+
+ return NULL; /* Not reached */
+}
+
+#endif /* !HAVE_NBTOOL_CONFIG_H || !HAVE_MKDTEMP */