pkgsrc/databases/postgresql-postgis/patches/patch-aa
gdt 8afb28c6cc Update to 1.5.1. Fix path to where postgis library is actually put.
Bug Fixes

    * #410, update embedded bbox when applying ST_SetPoint,
      ST_AddPoint ST_RemovePoint to a linestring
      (Paul Ramsey)
    * #411, allow dumping tables with invalid geometries
      (Sandro Santilli, for Regione Toscana-SIGTA)
    * #414, include geography_columns view when running upgrade scripts
      (Paul Ramsey)
    * #419, allow support for multilinestring in ST_Line_Substring
      (Paul Ramsey, for Lidwala Consulting Engineers)
    * #421, fix computed string length in ST_AsGML()
      (Olivier Courtin)
    * #441, fix GML generation with heterogeneous collections
      (Olivier Courtin)
    * #443, incorrect coordinate reversal in GML 3 generation
      (Olivier Courtin)
    * #450, wrong area calculation for geography features that cross
      the date line
      (Paul Ramsey)
    * Ensure support for upcoming 9.0 PgSQL release
      (Paul Ramsey)
2010-03-12 01:06:15 +00:00

22 lines
948 B
Text

$NetBSD: patch-aa,v 1.3 2010/03/12 01:06:16 gdt Exp $
--- postgis/Makefile.in.orig 2010-01-08 22:48:29.000000000 +0000
+++ postgis/Makefile.in
@@ -69,7 +69,7 @@ OBJS=$(PG_OBJS)
# older version of PostGIS, rather than with the static liblwgeom.a
# supplied with newer versions of PostGIS
PG_CPPFLAGS+=@CPPFLAGS@ -I../liblwgeom
-SHLIB_LINK+=@SHLIB_LINK@ ../liblwgeom/liblwgeom.a
+SHLIB_LINK+=@SHLIB_LINK@ ../liblwgeom/liblwgeom.la
# Extra files to remove during 'make clean'
EXTRA_CLEAN=$(SQL_OBJS)
@@ -103,7 +103,7 @@ endif
# Borrow the $libdir substitution from PGXS but customise by adding the version number
%.sql: %.sql.in
- sed 's,MODULE_PATHNAME,$$libdir/postgis-@POSTGIS_MAJOR_VERSION@.@POSTGIS_MINOR_VERSION@,g' $< >$@
+ sed 's,MODULE_PATHNAME,$$libdir/../libpostgis-@POSTGIS_MAJOR_VERSION@.@POSTGIS_MINOR_VERSION@.so,g' $< >$@
postgis_upgrade_15_minor.sql: postgis.sql
$(PERL) ../utils/postgis_proc_upgrade.pl $< 1.5 > $@