05fde70145
framework.
97 lines
3.3 KiB
Text
97 lines
3.3 KiB
Text
$NetBSD: patch-aa,v 1.3 2005/11/05 03:27:56 rillig Exp $
|
|
|
|
--- unix/Makefile.in.orig 2001-10-20 01:24:40.000000000 +0100
|
|
+++ unix/Makefile.in 2005-05-10 17:01:34.000000000 +0100
|
|
@@ -76,7 +76,7 @@
|
|
# The directory containing the Tcl sources and headers appropriate
|
|
# for this version of Tk ("srcdir" will be replaced or has already
|
|
# been replaced by the configure script):
|
|
-TCL_GENERIC_DIR = @TCL_SRC_DIR@/generic
|
|
+TCL_GENERIC_DIR = $(TCL_BIN_DIR)/../include/tcl/generic
|
|
|
|
# The directory containing the Tcl library archive file appropriate
|
|
# for this version of Tk:
|
|
@@ -100,7 +100,7 @@
|
|
#CFLAGS = $(CFLAGS_DEBUG)
|
|
#CFLAGS = $(CFLAGS_OPTIMIZE)
|
|
#CFLAGS = $(CFLAGS_DEBUG) $(CFLAGS_OPTIMIZE)
|
|
-CFLAGS = @CFLAGS@ @CFLAGS_DEFAULT@
|
|
+CFLAGS += @CFLAGS@ @CFLAGS_DEFAULT@
|
|
|
|
# Flags to pass to the linker
|
|
LDFLAGS_DEBUG = @LDFLAGS_DEBUG@
|
|
@@ -159,8 +159,8 @@
|
|
# "install" around; better to use the install-sh script that comes
|
|
# with the distribution, which is slower but guaranteed to work.
|
|
|
|
-INSTALL = @srcdir@/install-sh -c
|
|
-INSTALL_PROGRAM = ${INSTALL}
|
|
+INSTALL = ${LIBTOOL} --mode=install @srcdir@/install-sh -c
|
|
+INSTALL_PROGRAM = ${INSTALL} -s
|
|
INSTALL_DATA = ${INSTALL} -m 644
|
|
|
|
# The following specifies which Tcl executable to use for make targets
|
|
@@ -209,7 +209,7 @@
|
|
# The values of the symbolis normally set by the configure script.
|
|
|
|
STLIB_LD = @STLIB_LD@
|
|
-SHLIB_LD = @SHLIB_LD@
|
|
+SHLIB_LD = ${LIBTOOL} --mode=link @CC@ -rpath ${PREFIX}/lib
|
|
SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
|
|
|
|
# Additional search flags needed to find the various shared libraries
|
|
@@ -240,7 +240,8 @@
|
|
# either.
|
|
#----------------------------------------------------------------
|
|
|
|
-CC = @CC@
|
|
+CC = ${LIBTOOL} --mode=compile @CC@
|
|
+LD = ${LIBTOOL} --mode=link @CC@ -Wl,-R${PREFIX}/lib -Wl,-R${X11BASE}/lib
|
|
|
|
CC_SWITCHES_NO_STUBS = ${CFLAGS} ${CFLAGS_WARNING} ${SHLIB_CFLAGS} \
|
|
-I${UNIX_DIR} -I${GENERIC_DIR} \
|
|
@@ -373,6 +374,7 @@
|
|
rm -f ${TK_LIB_FILE}
|
|
@MAKE_LIB@
|
|
$(RANLIB) ${TK_LIB_FILE}
|
|
+ ${TOUCH} ${TK_LIB_FILE}
|
|
|
|
${STUB_LIB_FILE}: ${STUB_LIB_OBJS}
|
|
rm -f ${STUB_LIB_FILE}
|
|
@@ -391,9 +393,9 @@
|
|
|
|
|
|
wish: $(WISH_OBJS) $(TK_LIB_FILE) $(TK_STUB_LIB_FILE)
|
|
- $(CC) $(LDFLAGS) $(WISH_OBJS) \
|
|
+ $(LD) $(LDFLAGS) $(WISH_OBJS) \
|
|
@TK_BUILD_LIB_SPEC@ \
|
|
- $(WISH_LIBS) $(TK_CC_SEARCH_FLAGS) -o wish
|
|
+ $(WISH_LIBS) -o wish
|
|
|
|
# This rule is executed if the user tried to run tktest without first
|
|
# building tcltest in the Tcl bin directory. Just do it for them.
|
|
@@ -402,12 +404,12 @@
|
|
make tcltest
|
|
|
|
tktest: ${TCL_BIN_DIR}/tcltest $(TKTEST_OBJS) $(TK_LIB_FILE)
|
|
- ${CC} $(LDFLAGS) $(TKTEST_OBJS) \
|
|
+ ${LD} $(LDFLAGS) $(TKTEST_OBJS) \
|
|
@TK_BUILD_LIB_SPEC@ \
|
|
- $(WISH_LIBS) $(TK_CC_SEARCH_FLAGS) -o tktest
|
|
+ $(WISH_LIBS) -o tktest
|
|
|
|
xttest: test.o tkTest.o tkSquare.o $(TK_LIB_FILE)
|
|
- ${CC} $(LDFLAGS) test.o tkTest.o tkSquare.o \
|
|
+ ${LD} $(LDFLAGS) test.o tkTest.o tkSquare.o \
|
|
@TK_BUILD_LIB_SPEC@ \
|
|
$(WISH_LIBS) $(TK_LD_SEARCH_FLAGS) -lXt -o xttest
|
|
|
|
@@ -462,7 +464,7 @@
|
|
chmod +x $(UNIX_DIR)/mkLinks; \
|
|
fi
|
|
@echo "Installing $(TK_LIB_FILE) to $(LIB_INSTALL_DIR)/"
|
|
- @$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
|
|
+ @$(INSTALL_DATA) $(TK_LIB_FILE:C/\.so.*/.la/) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
|
|
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
|
|
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
|
|
@echo "Installing wish as $(BIN_INSTALL_DIR)/wish$(VERSION)"
|