pkgsrc/graphics/gthumb/patches/patch-ab
drochner c756f4dd2e update to 2.14.4
changes:
-bugfixes
-translation updates
2012-08-10 15:27:29 +00:00

44 lines
3.5 KiB
Text

$NetBSD: patch-ab,v 1.8 2012/08/10 15:27:29 drochner Exp $
Build eggsmclient-osx.c (required on Mac OS X).
--- copy-n-paste/Makefile.in.orig 2012-03-25 18:34:06.000000000 +0000
+++ copy-n-paste/Makefile.in
@@ -54,6 +54,7 @@ libeggsmclient_la_DEPENDENCIES = $(am__D
$(am__DEPENDENCIES_1)
am_libeggsmclient_la_OBJECTS = libeggsmclient_la-eggdesktopfile.lo \
libeggsmclient_la-eggsmclient.lo \
+ libeggsmclient_la-eggsmclient-osx.lo \
libeggsmclient_la-eggsmclient-xsmp.lo
libeggsmclient_la_OBJECTS = $(am_libeggsmclient_la_OBJECTS)
AM_V_lt = $(am__v_lt_@AM_V@)
@@ -311,6 +312,7 @@ libeggsmclient_la_SOURCES = eggdesktopfi
eggdesktopfile.c \
eggsmclient.h \
eggsmclient.c \
+ eggsmclient-osx.c \
eggsmclient-private.h \
eggsmclient-xsmp.c
@@ -367,6 +369,7 @@ distclean-compile:
-rm -f *.tab.c
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libeggsmclient_la-eggdesktopfile.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libeggsmclient_la-eggsmclient-osx.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libeggsmclient_la-eggsmclient-xsmp.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libeggsmclient_la-eggsmclient.Plo@am__quote@
@@ -405,6 +408,13 @@ libeggsmclient_la-eggsmclient.lo: eggsmc
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libeggsmclient_la_CFLAGS) $(CFLAGS) -c -o libeggsmclient_la-eggsmclient.lo `test -f 'eggsmclient.c' || echo '$(srcdir)/'`eggsmclient.c
+libeggsmclient_la-eggsmclient-osx.lo: eggsmclient-osx.c
+@am__fastdepCC_TRUE@ $(AM_V_CC)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libeggsmclient_la_CFLAGS) $(CFLAGS) -MT libeggsmclient_la-eggsmclient-osc.lo -MD -MP -MF $(DEPDIR)/libeggsmclient_la-eggsmclient-osx.Tpo -c -o libeggsmclient_la-eggsmclient-osx.lo `test -f 'eggsmclient-osx.c' || echo '$(srcdir)/'`eggsmclient-osx.c
+@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/libeggsmclient_la-eggsmclient-osx.Tpo $(DEPDIR)/libeggsmclient_la-eggsmclient-osx.Plo
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='eggsmclient-osx.c' object='libeggsmclient_la-eggsmclient-osx.lo' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libeggsmclient_la_CFLAGS) $(CFLAGS) -c -o libeggsmclient_la-eggsmclient-osx.lo `test -f 'eggsmclient-osx.c' || echo '$(srcdir)/'`eggsmclient-osx.c
+
libeggsmclient_la-eggsmclient-xsmp.lo: eggsmclient-xsmp.c
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libeggsmclient_la_CFLAGS) $(CFLAGS) -MT libeggsmclient_la-eggsmclient-xsmp.lo -MD -MP -MF $(DEPDIR)/libeggsmclient_la-eggsmclient-xsmp.Tpo -c -o libeggsmclient_la-eggsmclient-xsmp.lo `test -f 'eggsmclient-xsmp.c' || echo '$(srcdir)/'`eggsmclient-xsmp.c
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/libeggsmclient_la-eggsmclient-xsmp.Tpo $(DEPDIR)/libeggsmclient_la-eggsmclient-xsmp.Plo