a4b957da48
Upstream changes: bug fixes. Package changes: avoid ".." in paths by changing WRKSRC and using CONFIGURE_DIRS. Add chunk to configure.in to avoid build failures I was seeing on NetBSD-current/amd64.
17 lines
391 B
Text
17 lines
391 B
Text
$NetBSD: patch-af,v 1.2 2007/03/18 18:49:47 wiz Exp $
|
|
|
|
--- pr/src/Makefile.in.orig 2006-10-19 00:39:28.000000000 +0000
|
|
+++ pr/src/Makefile.in
|
|
@@ -170,6 +170,12 @@ OS_LIBS = -ldl
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(OS_ARCH),NetBSD)
|
|
+ifeq ($(USE_PTHREADS), 1)
|
|
+OS_LIBS = -lpthread
|
|
+endif
|
|
+endif
|
|
+
|
|
ifeq ($(OS_ARCH),HP-UX)
|
|
ifeq ($(USE_PTHREADS), 1)
|
|
ifeq (,$(filter-out B.10.10 B.10.20,$(OS_RELEASE)))
|