pkgsrc/x11/kdebase2/patches/patch-ay
skrll a100f5d455 Update to KDE 2.2.2
Closes pkg/14728 from Mark Davies <mark@mcs.vuw.ac.nz>. Changes from him
with updates from myself.

From www.kde.org... The principal improvements over KDE 2.2.1, release two
months ago, include:

o security-related
	- SSL certificate loading
	- symlink vulnerability in .wmrc access by KDM introduced in 2.2
	- security problem with eFax (used by klprfax)
	- potential problem in PAM invocation by KDM
	- potential harmful side-effect of failed KDM session starts

o new features
	- added support for CodeWeavers' CrossOver plug-in (provides support
	  for QuickTime, etc.)
	- added support for the wheelmouse for scrolling through the
	  KGhostview PS/PDF viewer component
	- ability to search for multiple patterns at a time in the file
	  search dialog
	- debugging multi-threaded applications with KDevelop

o improvements/fixes
	- handling of HTTP links that redirect to FTP
	- POST using SSL through a proxy and sending headers through proxies
	- saving of recently-selected files in the file dialog
	- handling of non-ASCII characters over SMB
	- toolbar button captions with certain styles
	- selecting items with the mouse in Konqueror
	- sorting in Konqueror's textview
	- saving current settings as a theme in the theme manager
	- crashes in KMail with certain mails
	- crash on invoking the KDM chooser
	- non-Latin languages with KDevelop

performance
	- icon loading optimized
	- file dialog speedups
	- stop spinning SMB client processes
	- handling of large files in Kate
2001-12-03 15:37:14 +00:00

22 lines
1.3 KiB
Text

$NetBSD: patch-ay,v 1.3 2001/12/03 15:37:19 skrll Exp $
--- kcontrol/kio/Makefile.in.orig Sat Nov 10 07:58:20 2001
+++ kcontrol/kio/Makefile.in
@@ -291,7 +291,7 @@
libkcm_kio_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
-libkcm_kio_la_LIBADD = $(LIB_KSYCOCA) $(LIB_KFILE)
+libkcm_kio_la_LIBADD = $(LIB_KSYCOCA) $(LIB_KFILE) ${KDE_RPATH}
check_PROGRAMS = test
test_SOURCES = $(libkcm_kio_la_SOURCES) test.cpp
@@ -360,7 +360,7 @@
#>- DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
#>+ 4
-KDE_DIST=UA-DESKTOP-FILE-HOWTO cookies.desktop useragent.desktop useragentdlg.h uagentproviderdlg.h proxy.desktop policydlg.h ksmboptdlg.h kcookiesmanagement.h fakeuaprovider.h netpref.desktop kproxydlg.h kcookiesmain.h kproxydlgui.ui kcookiespolicies.h uninstall.desktop smb.desktop uasprovider.desktop netpref.h smbrodlg.h
+KDE_DIST=policydlg.h ksmboptdlg.h kcookiesmanagement.h UA-DESKTOP-FILE-HOWTO kproxydlgui.ui fakeuaprovider.h useragentdlg.h uagentproviderdlg.h cookies.desktop kcookiespolicies.h netpref.desktop uninstall.desktop smb.desktop proxy.desktop useragent.desktop uasprovider.desktop kproxydlg.h netpref.h kcookiesmain.h smbrodlg.h
DISTFILES= $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)