51f599ac90
Buildlink1 -> buildlink2. Update homepage. * Changes in version 1.8.9 August 2, 2002 - declare this version 1.8.9 - general - split rpm into: graphviz, graphviz-tcl, graphviz-graphs, graphviz-devel - gcc3 warning cleanup - Install lincdt, libgraph, libagraph, libgd, libpathplan, libexp, and libpack so that they can be used by other programs. Headers and man3 in graphviz-devel - dynagraph, graphsearch - New tools based on libagraph and written in C++ - dot, neato, twopi - Add node and edge tooltips for use with -Tcmap \N,\E,\H,\T substitutions also work in tooltips. - Add alt="label_string" to -Tcmap - Add edge-label and port mappings to -Tps and -Tps2 so that edges can be hyperlinked in PDF documents. - Add support for \E (edge name), \H (head-node name), \T (tail-node name) substitutions in edge labels and edge URLs - Add support for stylesheet="file.css" for use in -Tsvg - Fix -Tpic to work with recent gpic (Bruce Lilly) - Fix alignment of imagemaps to images. - Fix "transparent" color support in -Tsvg - Fix support for graph [URL="default.html"] in -Tsvg and -Tcmap. - Fix '&' escaping in URLs in -Tsvg - Fix infinite loop in dot layout algorithm - Fix text rotations again (hopefully freetype is stable now.) - Cluster layout improvements - Clean up warning messages from pathplan - Consolidation of mapping code from imapgen.c and ismapgen.c into mapgen.c - gpr - Added additional mode to extract components based sharing an edge or a cluster - Fix test for getopt - tcl-based tools - Disable tcl-based tool building if tcl/tk not available with stubs support. - documentation updates: FAQ, dotguide, dot.1 * Changes in version 1.8.8 July 5, 2002 - declare 1.8.7 a "brown bag" release and declare this version 1.8.8 - remove wrong assert in gdgen.c - fix graph centering in bitmap outputs - provide enough margins - fix line widths after scaling (test with directed/proc3d.dot) - fix text rotations (requires libfreetype.so.6.3.1) (test with directed/NaN.dot) * Changes in version 1.8.7 July 5, 2002 - declare this version 1.8.7 - Fix missing "]" in ihi demo. July 2, 2002 - Add URL mappings for clusters: svg,svgz,ps,ismap,imap,cmap. - Fix to avoid white edges in bitmap outputs when bgcolor is set. - Improve sizing and position of strings in bitmap outputs when using builtin fonts (when font file not found). - Fix \N substitution in edge URLs in imap and cmap outputs. - Add -Tcmap for client-side imagemaps. - Generate warnings instead of access violation for EPSF file problems. - Various spline fixes in neato. - Fixes to pack.c - Add feature to ccomps to allow extraction of individual component by number or node. - Cdt make to use iffe provided in the tools directory. - Various Makefile.old fixes. - Use HAVE_LIBZ to remove GD2 format if libz not available. Now bare-bones programs can be built without any add-on libraries. - Modified dot grammar to allow simple name attributes in attribute lists. Thus, [splines] is equivalent to [splines=true]. Adopted the same convention for command line attributes -G, -E and -N. In addition, such command line attributes now override any competing initial attribute statements. - HP-UX 11.11 build fixes for struct dioattr. - Fix for bug #158 "Nodes disappear with ports" - Various Windows-specific #ifdefs - Fix edge coordinates in -Tplain. * Changes in version 1.8.6 May 24, 2002 - declare this version 1.8.6 May 19, 2002 - Fixed segfault from use of bgcolor in clusters. May 15, 2002 - Changed install location of architecture-independent demo scripts and graphs to <prefix>/share/graphviz/ to conform to FHS. - Avoid multiple linking of libfreetype (and others) which caused problems on SunOS-2.8. May 6, 2002 - Factored out some duplicated arrow code from dotgen/splines.c and neatorgen/splines.c into common/arrows.c. - Added new arrow types: halfopen, box, obox, crow. - Touched up the arrow designs so that they look better at default size. - Modified/extended graphs/directed/newarrows.dot to show new arrows. May 3, 2002 - Added some UML arrow types from Diomidis Spinellis <dds@aueb.gr> empty, invempty, open, diamond, odiamond. May 2, 2002 - Added new pack option to neato. This causes each connected component to be laid out separately, and then the resulting graphs are packed together in a single layout. - Amended neato to accept new tee arrowhead. April 19, 2002 - Coords of rectangles changed to left/top right/bottom in -Timap. - Generate COPYING from LICENSE.html during ./authogen.sh, remove COPYING from CVS. April 16, 2002 - Minor license file patches. - Corrected one of those reversed flat edge bugs again.
73 lines
2.7 KiB
Text
73 lines
2.7 KiB
Text
$NetBSD: patch-ab,v 1.5 2002/08/28 13:49:36 seb Exp $
|
|
|
|
--- configure.in.orig Fri Aug 2 22:55:20 2002
|
|
+++ configure.in
|
|
@@ -48,7 +48,10 @@ DEFAULT_FONTPATH="C:/WINDOWS/FONTS;C:/WI
|
|
PATHSEPARATOR=";"
|
|
else
|
|
# This sucks! Whatever happened to standards for file system layout?
|
|
-DEFAULT_FONTPATH="/usr/X11R6/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/truetype:/usr/X11R6/lib/X11/fonts/TTF:/usr/share/fonts/TrueType:/usr/share/fonts/truetype:/usr/openwin/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/Type1"
|
|
+DEFAULT_FONTPATH="${X11PREFIX}/lib/X11/fonts/TrueType:${X11PREFIX}/lib/X11/fonts/truetype:${X11PREFIX}/lib/X11/fonts/Type1"
|
|
+if test x"$X11PREFIX" != x"$X11BASE" ; then
|
|
+DEFAULT_FONTPATH="${DEFAULT_FONTPATH}:${X11BASE}/lib/X11/fonts/TrueType:${X11BASE}/lib/X11/fonts/truetype:${X11BASE}/lib/X11/fonts/Type1"
|
|
+fi
|
|
PATHSEPARATOR=":"
|
|
fi
|
|
fi
|
|
@@ -177,7 +180,7 @@ if test -f $TCLCONFIG; then
|
|
. $file
|
|
# TCL STUBS support is required
|
|
if test "${TCL_SUPPORTS_STUBS}" = "1"; then
|
|
- TCL_SUBDIRS="tclstubs tclhandle gdtclft tcldot tcldgr tcldgl tclpathplan"
|
|
+ TCL_SUBDIRS="tclhandle gdtclft tcldot tcldgr tcldgl tclpathplan"
|
|
TCL_PKGINDEX="gdtclft/pkgIndex.tcl tcldot/pkgIndex.tcl tcldgr/pkgIndex.tcl tcldgl/pkgIndex.tcl tclpathplan/pkgIndex.tcl"
|
|
else
|
|
AC_MSG_WARN([Tcl does not have STUBs support, perhaps it is too old? The packages: "gdtclft tcldot tcldgr tcldgl tclpathplan" will not be built])
|
|
@@ -266,7 +269,7 @@ if test -f $TKCONFIG; then
|
|
file=${TKCONFIG}
|
|
. $file
|
|
if test "${TCL_SUPPORTS_STUBS}" = "1"; then
|
|
- TK_SUBDIRS="tkstubs tkspline"
|
|
+ TK_SUBDIRS="tkspline"
|
|
TK_PKGINDEX="tkspline/pkgIndex.tcl"
|
|
else
|
|
AC_MSG_WARN([Tcl does not have STUBs support, so neither does Tk. The packages: "tkspline" will not be built])
|
|
@@ -610,36 +613,12 @@ AC_MSG_RESULT(no)])
|
|
|
|
# -----------------------------------
|
|
# tclInt.h
|
|
-if test -f "$TCL_SRC_DIR/generic/tclInt.h"; then
|
|
-TCLINT_INCLUDES="-I$TCL_SRC_DIR/generic"
|
|
-else
|
|
-if test -f "/usr/include/tclInt.h"; then
|
|
-TCLINT_INCLUDES=""
|
|
-else
|
|
-if test -f "/usr/local/include/tclInt.h"; then
|
|
-TCLINT_INCLUDES="-I/usr/local/include"
|
|
-else
|
|
-TCLINT_INCLUDES="-I$TOP_DIR/tclstubs"
|
|
-fi
|
|
-fi
|
|
-fi
|
|
+TCLINT_INCLUDES="-I${BUILDLINK_PREFIX_TCL}/include/tcl/generic"
|
|
AC_SUBST(TCLINT_INCLUDES)
|
|
|
|
# -----------------------------------
|
|
# tkInt.h
|
|
-if test -f "$TK_SRC_DIR/generic/tkInt.h"; then
|
|
-TKINT_INCLUDES="-I$TK_SRC_DIR/generic"
|
|
-else
|
|
-if test -f "/usr/include/tkInt.h"; then
|
|
-TKINT_INCLUDES=""
|
|
-else
|
|
-if test -f "/usr/local/include/tkInt.h"; then
|
|
-TKINT_INCLUDES="-I/usr/local/include"
|
|
-else
|
|
-TKINT_INCLUDES="-I$TOP_DIR/tkstubs"
|
|
-fi
|
|
-fi
|
|
-fi
|
|
+TKINT_INCLUDES="-I${BUILDLINK_PREFIX_TK}/include/tk/generic"
|
|
AC_SUBST(TKINT_INCLUDES)
|
|
|
|
# -----------------------------------
|