* Optimization: A bunch of patches by M. Doliner (see svn log for more details) * Feature: Allow the service admin to see the occupants of every rooms * Feature: Allow the service admin to enter a room with nicknames locked even if his nickname isn't the one needed * Feature: option to disable room logging on the whole component * Feature: option to save room log files in subdirectories according to date * Feature: Patch by Smoku to hide empty rooms from disco/browse lists * Bugfix: Two vulnerabilities in mysql module * Bugfix: send code=110 when needed according to XEP-0045 * Bugfix: Fix crash when changing roles * Bugfix: Fixed a bug when entering/leaving a room, it was considered as a nick change * Bugfix: Corrected the errors sent by mu-conference * Bugfix: Better error code when choosing a nick not conform with the room policy * Bugfix: Fixed a segfault in the decline messages handler * Bugfix: Avoid a segfault when asking unique room name with a too big user jid * Bugfix: going in an infinite loop if the user invite the jid "" * Bugfix: Changed error handling - Don't kick a user if the message error is not delivery-related, otherwise user could be kicked when refusing a file transfer for example - If the user is not kicked, don't discard the error, send it to the other user/chatroom * Bugfix: Hide XEP-0203 delay nodes when sending back presences stanzas
8 lines
399 B
Text
8 lines
399 B
Text
$NetBSD: patch-src_jcomp_Makefile,v 1.1 2011/02/04 12:05:45 adam Exp $
|
|
|
|
--- src/jcomp/Makefile.orig 2011-02-04 09:44:51.000000000 +0000
|
|
+++ src/jcomp/Makefile 2011-02-04 09:45:02.000000000 +0000
|
|
@@ -3,2 +3 @@
|
|
-CC=gcc
|
|
-CFLAGS:=$(CFLAGS) -O2 -Wall -I../../include -I. `pkg-config --cflags glib-2.0` -D_REENTRANT
|
|
+CFLAGS:=$(CFLAGS) -Wall -I../../include -I. `pkg-config --cflags glib-2.0` -D_REENTRANT
|