34b3f2e05b
when calling gmake manually as well.
20 lines
739 B
Text
20 lines
739 B
Text
$NetBSD: patch-aa,v 1.2 2006/04/08 16:30:57 joerg Exp $
|
|
|
|
these utilities were written with qt2 but they still ok with qt3
|
|
|
|
--- icewm4vim/Makefile.orig 2005-03-07 15:55:33.000000000 +0000
|
|
+++ icewm4vim/Makefile 2005-03-07 15:54:07.000000000 +0000
|
|
@@ -1,10 +1,10 @@
|
|
INCLUDE_QT = -I$(QTDIR)/include
|
|
-LIB_QT = -L$(QTDIR)/lib
|
|
+LIB_QT = -L$(QTDIR)/lib -Wl,-R$(QTDIR)/lib ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}
|
|
|
|
all: icefonsel icecolsel
|
|
|
|
icefonsel: icefonsel.cpp
|
|
- g++ $(INCLUDE_QT) $(LIB_QT) -lqt icefonsel.cpp -o icefonsel
|
|
+ g++ $(INCLUDE_QT) $(LIB_QT) -lqt-mt icefonsel.cpp -o icefonsel
|
|
|
|
icecolsel: icecolsel.cpp
|
|
- g++ $(INCLUDE_QT) $(LIB_QT) -lqt icecolsel.cpp -o icecolsel
|
|
+ g++ $(INCLUDE_QT) $(LIB_QT) -lqt-mt icecolsel.cpp -o icecolsel
|