8fb76ee717
bulk of the porting work. Tested on SmartOS 32-bit. 64-bit builds currently fail, they should hopefully be fixed soon.
22 lines
751 B
Text
22 lines
751 B
Text
$NetBSD: patch-jdk_make_sun_security_ec_Makefile,v 1.1 2013/06/15 09:31:06 jperkin Exp $
|
|
|
|
GCC compatability.
|
|
|
|
--- jdk/make/sun/security/ec/Makefile.orig 2013-02-20 17:07:30.000000000 +0000
|
|
+++ jdk/make/sun/security/ec/Makefile
|
|
@@ -187,6 +187,15 @@ ifeq ($(NATIVE_ECC_AVAILABLE), true)
|
|
#
|
|
OTHER_CFLAGS += -DMP_API_COMPATIBLE -DNSS_ECC_MORE_THAN_SUITE_B
|
|
|
|
+ # gcc on solaris seems to define _POSIX_C_SOURCE or _XOPEN
|
|
+ # g++, on the otherhand, does not define either.
|
|
+ # It causes problems with g++: _B_FALSE instead of B_FALSE
|
|
+ ifeq ($(PLATFORM), solaris)
|
|
+ ifeq ($(CC_VERSION), gcc)
|
|
+ OTHER_CFLAGS += -D_XOPEN_SOURCE -D_XOPEN_VERSION=4 -D__EXTENSIONS__
|
|
+ endif # CC_VERSION
|
|
+ endif # PLATFORM
|
|
+
|
|
#
|
|
# Libraries to link
|
|
#
|