pkgsrc/databases/openldap/patches/patch-ab
tron 5eb9a5c340 Update "openldap" package to version 2.0.17. Major changes since version
1.2.13:
- LDAPv3 support
    + RFC 2251-2256
    + Language Tags (RFC 2596)
    + SASL (RFC2829)
    + TLS (RFC2830) and SSL (ldaps://)
    + named references
    + DNS SRV location
- IPv6 support
- LDAP over IPC support
- Updated C API
- LDIFv1 (RFC2849)
- Enhanced Standalone LDAP Server:
    + Updated Access Control System
    + Thread Pooling
    + DNS SRV referral backend (experimental)
    + LDAP backend (experimental)
    + SQL backend (experimental)
    + Better tools

This fixes PR pkg/14339 by Hauke Fath.
2001-10-25 16:15:44 +00:00

42 lines
1.2 KiB
Text

$NetBSD: patch-ab,v 1.3 2001/10/25 16:15:44 tron Exp $
--- build/lib-shared.mk.orig Wed Oct 11 04:32:05 2000
+++ build/lib-shared.mk Thu Oct 25 16:12:57 2001
@@ -7,7 +7,11 @@
## Makefile Template for Shared Libraries
##
-NT_LTFLAGS = --only-$(LINKAGE)
+.if ($(LINKAGE) == static)
+NT_LTFLAGS = -static
+.else
+NT_LTFLAGS =
+.endif
LTFLAGS = $(@PLAT@_LTFLAGS)
NT_DYN_LT_NO_UNDEF = -no-undefined
@@ -32,19 +36,11 @@
$(LIBRARY): version.lo
$(LTLIBLINK) -o $@ $(OBJS) version.lo $(EXTRA_LIBS)
- $(RM) ../$@
- d=`$(PWD)`; d=`$(BASENAME) $$d`; cd ..; $(LN_S) $$d/$@ $@; \
- t=`$(BASENAME) $@ .la`.a; $(RM) $$t; $(LN_S) $$d/.libs/$$t $$t
- if test "$(LINK_BINS_DYNAMIC)" = "yes"; then \
- d=`$(PWD)`; d=`$(BASENAME) $$d`; b=`$(BASENAME) $@ .la`; \
- cd .libs; t=`echo $$b*.$(DYN_EXT)`; (cd ../.. ; $(RM) $$t; \
- $(LN_S) $$d/.libs/$$t $$t); \
- if test "$(DYN_EXT)" != dll; then \
- t=`echo $$b.$(DYN_EXT).?`; cd ../.. ; \
- $(RM) $$t; \
- $(LN_S) $$d/.libs/$$t $$t; \
- fi \
- fi
+ @$(RM) ../$@
+ @for ext in a so so.1.0; do \
+ $(RM) ../`$(BASENAME) $@ .la`.$$ext; \
+ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.$$ext; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t); \
+ done
Makefile: $(top_srcdir)/build/lib-shared.mk