58878eced2
1.2.5.1 Core Release v1.2.5.1 Fix EXPORT_SYMBOL attribute for clang configure: check if eaccess() is available Control API control: remap - fix an infinite recursive call in the async callback control: remap - fix uninitialized value in parse_map_vindex() PCM API pcm: direct - remove dead code pcm: softvol - fix early exit in add_tlv_info() pcm: remove extra NULL checks in snd_pcm_dshare_open() pcm: remove extra NULL checks in snd_pcm_dsnoop_open() pcm: remove extra NULL checks in snd_pcm_dmix_open() pcm: direct - fix pcmp error path in _snd_pcm_direct_new() Timer API timer: remove dead code in _snd_timer_hw_open() Use Case Manager API configure: check if eaccess() is available ucm: include sys/wait.h to fix build on Android ucm_exec.c: Include limits.h explicitly to fix build on musl ucm: compound_merge() - fix use after free (and logic) ucm: fix possible memory leak in parse_verb_file() ucm: fix out-of-array access in rval_device_lookup_init() ucm: check error value in parse_lookup_query() ucm: fix possible NULL pointer dereference in uc_mgr_exec() ucm: find_exec() - fix memory leak (dir) ucm: fix if_eval_path() - access NULL pointer ucm: fix use after free in if_eval_regex_match() ucm: fix error path in execute_cfgsave() ucm: fix _alibpref string (add '.' delimiter to the end) ucm: add _alibpref to get the private device prefix Configuration conf: snd_config_get_card() remove unused assignment conf: remove dead code in snd_config_get_card() conf: fix load_for_all_cards() 1.2.5 Core Release v1.2.5 control: add missing src/conf/ctl/Makefile.am ucm: add LibraryConfig support control: remap plugin - initial version configure: bumb version to 1.2.5pre1 (for CI tests) Config API conf: add snd_config_make_path() function conf: add snd_config_is_empty() function conf: add snd_config_merge() function conf: introduce snd_config_get_card() function Control API control: remap - add no-op when the remapping is not active control: remap - don't allow I/O on renamed IDs ucm: add LibraryConfig support control: add empty plugin control: remap plugin - add docs control: doc - create controls plugin page control: remap plugin - initial version control: add _snd_ctl_open_child() control: shm - add missing continue to _snd_ctl_shm_open() ucm: move __snd_ctl_ascii_elem_id_parse prototype to control_local.h control: add __snd_ctl_add_elem_set() helper control: add snd_ctl_elem_id_compare_numid() function control: rename snd_ctl_elem_id_compare() to snd_ctl_elem_id_compare_set() control: fix the subdevice fields comparison in snd_ctl_elem_id_compare() control: better docs for snd_ctl_elem_id_compare() control: add snd_ctl_elem_id_compare() function control: snd_ctl_ascii_elem_id_get() - do not show unset numid conf: introduce snd_config_get_card() function control: improve snd_ctl_add_*_elem_set functions (access flags) control: fix iformation -> information typos Control Plugin API control: remap plugin - add docs control: doc - create controls plugin page HWDEP API conf: introduce snd_config_get_card() function I/O API output: Add snd_output_buffer_steal() function Mixer API mixer: simple - Fix "Capture Volume" and "Capture Switch" being seen as global controls mixer: simple - use for loop in base_len() mixer: simple - Unify simple_none: base_len() exception handling PCM API pcm: hw - correct the comment in snd_pcm_hw_state() pcm: hw - fix again snd_pcm_hw_state() when the driver was disconnected pcm: hw - fix snd_pcm_hw_state() pcm: fix open in direct plugins - wrong pointer assignment pcm: direct - move the direct struct init to _snd_pcm_direct_new() pcm: dshare - fix shared memory pointer check ucm: add LibraryConfig support pcm: empty plugin - fix the docs pcm: softvol - improve TLV data check for new configs pcm: fix snd_pcm_plugin_status() conf: introduce snd_config_get_card() function pcm: softvol - make snd_pcm_parse_control_id private pcm: softvol - do not set TLV access flags for the switch pcm: pcm_ioplug - fix the avail_update mmap capture copy issue pcm: share: Pass appl_ptr and hw_ptr in snd_pcm_status() pcm: null: Pass appl_ptr and hw_ptr in snd_pcm_status() pcm: ioplug: Pass appl_ptr and hw_ptr in snd_pcm_status() pcm: direct: Fix the missing appl_ptr update pcm: dmix/dshare - delay calculation fixes and cleanups pcm_plugin: set the initial hw_ptr/appl_ptr from the child pcm pcm: rate - fix the capture delay values pcm: rate - use pcm_frame_diff() on related places pcm: plugin - fix status code for capture pcm: rate - use pcm_frame_diff() in snd_pcm_rate_playback_internal_delay() pcm: ioplug - fix the delay calculation for old plugins pcm: rate - tidy up snd_pcm_rate_avail_update() pcm: ioplug - fix the delay calculation in the status callback Revert "pcm_plugin: fix delay" pcm: plugin - optimize sync in snd_pcm_plugin_status() pcm: plugin - tidy snd_pcm_plugin_avail_update() pcm: plugin status - revert the recent changes pcm: plugin status - fix the return value (regression) pcm: fix __snd_pcm_state() return value pcm_multi: remove dead assignment from _snd_pcm_multi_open pcm: remove dead assignments from snd_pcm_rate_(commit_area|grab_next_period) pcm: Fix a typo in SND_PCM_AUDIO_TSTAMP_TYPE_LAST definition pcm: Add snd_pcm_audio_tstamp_type_t constants pcm: set the snd_pcm_ioplug_status() tstamp field pcm: snd_pcm_mmap_readi - fix typo in comment RawMidi API ucm: add LibraryConfig support conf: introduce snd_config_get_card() function rawmidi: fix memory leak in snd_rawmidi_virtual_open Sequencer API seq: fix snd_seq_parse_address() ucm: add LibraryConfig support Timer API timer: fix sizeof operator mismatch in snd_timer_query_hw_open Topology API topology/pcm.c: remove duplicated AC97 hw format topology: fix 'parse_tuple_set() - remove dead condition code' topology: sort_config() cleanups - use goto for the error path topology: parse_tuple_set() - remove dead condition code topology: tplg_decode_pcm() - add missing log argument (compress) topology: tplg_add_widget_object() - do not use invalid elem_ctl topology: tplg_pprint_integer() fix coverity uninitalized variable error topology: use inclusive language in documentation topology: use inclusive language for fsync topology: use inclusive language for bclk Use Case Manager API ucm: compound_merge - use snd_config_merge() ucm: recognize first '-' character as ignore error for exec/shell ucm: cfg-save - allow to save the sub-tree including root keys ucm: libconfig - merge not override items ucm: libconfig parser - fix memory leaks ucm: add cfg-save command ucm: fix memory leak in execute_cset() ucm: parse LibraryConfig also in the toplevel file ucm: fix regexec() REG_NOMATCH state handling for define regex ucm: add exec sequence command ucm: Fix sysw sequence command not working when requesting to ignore errors ucm: fix the local ucm control device name caching ucm: limit the master config scan to conf.virt.d ucm: fixed find-device substitution (non-continuous PCM devices) ucm: allow to escape the trailing variable substitution character ucm: find-device / pcm - the ctl_list may be empty ucm: add missing uc_mgr_card_close() call to snd_use_case_mgr_open() ucm: cosmetic code reshuffle in rval_lookup_main() ucm: fix uc_mgr_has_local_config() ucm: rewrite device value only when the local config exists ucm: return error if fixedboot_list is empty ucm: return error if boot_list is empty ucm: ucm_filename() - avoid double // ucm: handle better the system() call ucm: add LibraryConfig support ucm: add ${ConfLibDir} substitution ucm: add ctl-remove sequence command to delete controls from UCM ucm: add cset-new sequence command to create new controls from UCM ucm: move __snd_ctl_ascii_elem_id_parse prototype to control_local.h ucm: add Path condition type ucm: rename sysset to sysw ucm: warn about unknown sequence commands ucm: implement sysset sequence command ucm: ucm_main.c - cosmetic tab cleanups ucm: add _fboot / FixedBootSequence ucm: fix two error messages ucm: add ${find-card} and ${find-device} substitutions ucm: uc_mgr_substitute_tree() fix use after free ucm: fix possible memory leak in parse_verb_file() ucm: fix bad frees in get_list0 and get_list20 /Makefile.am Makefile: Add README.md to EXTRA_DIST /include/Makefile.am include: try to fix the out-of-source-tree build include: fix out-of-source-tree build include: fix SND_LIB_VER() macro include: add SND_LIB_VER() macro control: remap plugin - add docs Configuration conf: snd_config_merge() - substitute non-compound config handles conf: snd_config_merge() - merge (concat) correctly arrays conf: return count of items in snd_config_is_array() conf: print quoted string more wisely ucm: cfg-save - allow to save the sub-tree including root keys conf: fix snd_config_merge() - merge schema conf: load the card specific configurations to the config sub-tree conf: add snd_config_make_path() function conf: add snd_config_is_empty() function conf: _snd_config_evaluate - remove 'delete compound members' call conf: fix snd_config_substitute() - memory leak conf: fix snd_config_merge() - double free in overwrite mode alsa: conf - use card number roots for device redirects conf: extend load_for_all_cards hook (id/value table) control: add missing src/conf/ctl/Makefile.am conf: usb - correct 'SB Omni Surround 5.1' iec958 device conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device Remove non-existent SPDIF output on Dell AE515 conf: No SPDIF on Plantronics 3220 headset conf: add snd_config_merge() function conf: add /var/lib/alsa/conf.d directory lookup conf: add /var/lib/alsa/card<NUMBER>.conf.d directory lookups conf: extend hook load_for_all_cards conf: make ctl.default and sysdefault devices more universal conf: Fix invalid free at parse_args() conf: fix memory leak on the error path in parse_args() conf: snd_config_save() - print arrays as [] not the internal representation conf: improve the tabulator level prints conf: introduce snd_config_get_card() function conf: HDA-Intel: increase the max number of HDMI/DP output to 11 conf: USB - add "Xonar U7 MKII" to USB-Audio.pcm.iec958_device conf: fix return code in _snd_config_load_with_include confmisc: fix memory leak in snd_func_concat conf: fix get_hexachar() return value conf: fix use after free in _snd_config_load_with_include Documentation control: doc - create controls plugin page Dynamic Loader helpers dlmisc: fix snd_plugin_dir locking for not DL_ORIGIN_AVAILABLE dlmisc: the snd_plugin_dir_set / snd_plugin_dir must be declared even for \!DL_ORIGIN_AVAILABLE I/O subsystem output: Add snd_output_buffer_steal() function Kernel Headers topology: use inclusive language for fsync topology: use inclusive language for bclk Test/Example code test: audio_time - fix timestamp2ns() and usage() test/audio_time: Make use of SND_PCM_AUDIO_TSTAMP_TYPE constants Utils utils/alsa.m4: another quick fix for the brackets utils/alsa.m4: a quick fix for missing end brackets utils/alsa.m4: update for newer autoconf.
20 lines
506 B
C
20 lines
506 B
C
$NetBSD: patch-src_ucm_parser.c,v 1.9 2021/06/28 10:10:50 wiz Exp $
|
|
|
|
* SunOS has no dirent d_type
|
|
|
|
--- src/ucm/parser.c.orig 2020-06-29 10:51:08.000000000 +0000
|
|
+++ src/ucm/parser.c
|
|
@@ -2220,7 +2220,13 @@ static int filename_filter(const struct
|
|
{
|
|
if (dirent == NULL)
|
|
return 0;
|
|
+#ifdef __sun
|
|
+ struct stat s;
|
|
+ stat(dirent->d_name, &s);
|
|
+ if (s.st_mode & S_IFDIR) {
|
|
+#else
|
|
if (dirent->d_type == DT_DIR) {
|
|
+#endif
|
|
if (dirent->d_name[0] == '.') {
|
|
if (dirent->d_name[1] == '\0')
|
|
return 0;
|