pkgsrc/devel/scons/patches/patch-setup.py
adam 36c8f896c9 scons: updated to 3.0.4
RELEASE 3.0.4:
- Improve finding of Microsoft compiler: add a 'products' wildcard
  in case 2017 Build Tools only is installed as it is considered a separate
  product from the default Visual Studio
- Add TEMPFILESUFFIX to allow a customizable filename extension.
- Improved support for VC14.1 and Visual Studio 2017, as well as arm and arm64 targets.
- Initial support for ARM targets with Visual Studio 2017
- Update TempFileMunge class to use PRINT_CMD_LINE_FUNC
- Enhance cpp scanner regex logic to detect if/elif expressions without whitespaces but
  parenthesis like "#if(defined FOO)" or "#elif!(BAR)" correctly.

RELEASE 3.0.3:
NOTE: 3.0.2 release was dropped because there was a packaging bug. Please consider all 3.0.2
    content.
- Fixes to packaging logic.  Ensuring the SCons.Tool.clangCommon module is added
  to the release packages.
- Modify scons.bat script to check for scons python script without .py extension if no file
  scons.py exists. This enables an all platform wheel to work.
- Update doc examples to work with Python 3.5+:  map() now returns an iterable instead of a list.
2019-03-05 19:30:01 +00:00

23 lines
872 B
Python

$NetBSD: patch-setup.py,v 1.1 2019/03/05 19:30:01 adam Exp $
Use PKGMANDIR.
--- setup.py.orig 2019-01-23 17:10:54.000000000 +0000
+++ setup.py
@@ -30,7 +30,6 @@ import distutils.command.install_data
import distutils.command.install
import distutils.core
import distutils
-import setuptools
"""
NOTE: Installed SCons is not importable like usual Python packages. It is
executed explicitly with command line scripts. This allows multiple
@@ -380,7 +379,7 @@ class install_data(_install_data):
if is_win32:
dir = 'Doc'
else:
- dir = os.path.join('man', 'man1')
+ dir = os.path.join(os.getenv("PKGMANDIR"), 'man1')
self.data_files = [(dir, man_pages)]
man_dir = os.path.join(self.install_dir, dir)
msg = "Installed SCons man pages into %s" % man_dir