pkgsrc/wm/bbkeys09/patches/patch-src_KeyClient.cpp
he 680da07fcc Update bbkeys to version 0.9.1.
Pkgsrc changes:
 * Add a bugfix patch for an LP64 problem in the X11 protocol handling, from
   FreeBSD ports tree
 * Add a patch to complete initialization of pointers, also from FreeBSD
 * Add dependency on libXft, it appears to be required

Upstream changes:
 * Add sendToPreviousWorkspace and sendToNextWorkspace functions
 * Add new config option: followWindowOnSend, allows bbkeys to change
   workspace to the space it just sent a window to
 * Fix for underquoted definitions in configure.ac
 * Fix annoying behaviour when cycling through windows on all workspaces,
   no longer flip workspace when doing this
 * Add config option includeIconifiedWindowsInCycle to include iconified
   windows in window cycling list
2015-11-17 15:59:13 +00:00

26 lines
579 B
C++

$NetBSD: patch-src_KeyClient.cpp,v 1.2 2015/11/17 15:59:13 he Exp $
Include strings.h too.
Initialize all pointers.
--- src/KeyClient.cpp.orig 2008-12-22 01:52:35.000000000 +0000
+++ src/KeyClient.cpp
@@ -46,6 +46,7 @@ extern "C" {
#include <sys/types.h>
#include <sys/wait.h>
+#include <strings.h>
}
@@ -104,6 +105,10 @@ KeyClient::KeyClient (int argc, char **a
_netclient = new Netclient(this->display());
_active = _clients.end();
+ // Initialize uninitialized pointers to NULL
+ _keybindings = NULL;
+ config_check_timer = NULL;
+
initialize();
}