pkgsrc/lang/icon/patches/patch-aw
jtb be443f0c5e Update to version 9.4.2.
Notable changes in this latest version are listed here. Some code
   cleanup work and documentation editing has also been done.

  256-color limit removed

   Icon's X-windows interface previously limited each window to 256
   colors at one time. This limitation has been removed for the TrueColor
   displays provided by most modern computers. Median-cut quantization is
   used to select 256 image colors when WriteImage() is called to write a
   GIF file.

  Library changes

   As usual, several files in the Icon program library have been added or
   edited. The core library files, however, remain stable.

  Minor changes

     * The command "icon - [args]" can now be used to execute a source
       program read from standard input.
     * A new "icont -N" flag suppresses embedding of an iconx path in the
       generated executable
     * The configuration directory has been restructured.
     * Several obsolete configurations have been removed.
     * The environment variables HEAPSIZE and BLOCKSIZE no longer
       function as undocumented alternatives to BLKSIZE. The GNU ls
       utility uses BLOCKSIZE for other purposes, leading to confusion.
     * "make Install" has been changed to never delete anything. It now
       creates a new directory rather than altering an existing one.
2003-06-06 08:58:42 +00:00

37 lines
983 B
Text

$NetBSD: patch-aw,v 1.5 2003/06/06 08:58:43 jtb Exp $
--- src/common/Makefile.orig
+++ src/common/Makefile
@@ -5,7 +5,7 @@
munix.o literals.o rswitch.o alloc.o long.o getopt.o time.o\
save.o xwindow.o dlrgint.o ipp.o
-common: doincl $(OBJS) gpxmaybe
+common: doincl patchstr $(OBJS) fixheaders gpxmaybe
doincl: doincl.c ../h/arch.h
$(CC) $(CFLAGS) -o doincl doincl.c
@@ -13,13 +13,22 @@
patchstr: patchstr.c
$(CC) $(CFLAGS) -o patchstr patchstr.c
+ cp patchstr ../../bin
+
+fixheaders:
+ cd ../h; for f in *.h; do \
+ sed -e 's:../h/::g;s:../xpm/::g' $$f > ../../lib/icon/$$f; \
+ done
gpxmaybe:
-if [ "x$(XL)" != "x" ]; then $(MAKE) $(GDIR); fi
xpm:
cd ../xpm; $(MAKE) libXpm.a
- cp -p ../xpm/libXpm.a ../../bin/libIgpx.a
+ cp -p ../xpm/libXpm.a ../../lib/icon/libIgpx.a
+ cd ../xpm; for f in *.h; do \
+ sed -e 's:../h/::g;s:../xpm/::g' $$f > ../../lib/icon/$$f; \
+ done
wincap:
cd ../wincap; $(MAKE) libWincap.a