pkgsrc/devel/nbitools/patches/patch-ac
jlam 403042f126 * Modify comments in installed config files to match what's happening.
* Modify xmkmf so that we can override the imake command invoked via an
  environment variable IMAKE_CMD.
* Drop the nbitools/buildlink3.mk file as it's no longer used by either
  canna or sj3 for package builds.

Bump the PKGREVISION to 4.
2006-07-05 04:59:47 +00:00

40 lines
907 B
Text

$NetBSD: patch-ac,v 1.3 2006/07/05 04:59:47 jlam Exp $
--- config/util/xmkmf.cpp.orig 1997-08-22 04:21:46.000000000 -0400
+++ config/util/xmkmf.cpp
@@ -7,7 +7,7 @@ XCOMM $XConsortium: xmkmf.cpp /main/22 1
usage="usage: $0 [-a] [top_of_sources_pathname [current_directory]]"
-configdirspec=CONFIGDIRSPEC
+configdirspec="-I"CONFIGDIRSPEC
topdir=
curdir=.
do_all=
@@ -41,10 +41,16 @@ else
args="-I$topdir/config/cf -DTOPDIR=$topdir -DCURDIR=$curdir"
fi
-echo imake $args
+case "$IMAKE_CMD" in
+"") imake_cmd="BINDIRSPEC/imake" ;;
+*) imake_cmd="$IMAKE_CMD" ;;
+esac
+IMAKE_CMD="$imake_cmd"; export IMAKE_CMD
+
+echo $imake_cmd $args
case "$do_all" in
yes)
- imake $args &&
+ $imake_cmd $args &&
echo "make Makefiles" &&
make Makefiles &&
echo "make includes" &&
@@ -53,6 +59,6 @@ yes)
make depend
;;
*)
- imake $args
+ $imake_cmd $args
;;
esac