27 lines
931 B
Text
27 lines
931 B
Text
$NetBSD: patch-me,v 1.2 2010/04/26 12:38:00 tnn Exp $
|
|
|
|
Add DragonFly support.
|
|
Disable assembly routines in freebl on Linux (PR pkg/43146)
|
|
|
|
--- mozilla/security/nss/lib/freebl/Makefile.orig 2010-03-17 18:33:57.000000000 +0000
|
|
+++ mozilla/security/nss/lib/freebl/Makefile
|
|
@@ -154,7 +154,9 @@ ifeq ($(USE_N32),1)
|
|
endif
|
|
endif
|
|
|
|
-ifeq ($(OS_TARGET),Linux)
|
|
+# pkgsrc PR pkg/43146
|
|
+#ifeq ($(OS_TARGET),Linux)
|
|
+ifeq (true, false)
|
|
ifeq ($(CPU_ARCH),x86_64)
|
|
ASFILES = arcfour-amd64-gas.s mpi_amd64_gas.s
|
|
ASFLAGS += -march=opteron -m64 -fPIC -Wa,--noexecstack
|
|
@@ -224,7 +226,7 @@ endif
|
|
# to bind the blapi function references in FREEBLVector vector
|
|
# (ldvector.c) to the blapi functions defined in the freebl
|
|
# shared libraries.
|
|
-ifeq (,$(filter-out BSD_OS FreeBSD Linux NetBSD OpenBSD, $(OS_TARGET)))
|
|
+ifeq (,$(filter-out BSD_OS DragonFly FreeBSD Linux NetBSD OpenBSD, $(OS_TARGET)))
|
|
MKSHLIB += -Wl,-Bsymbolic
|
|
endif
|
|
|