pkgsrc/security/gnutls/patches/patch-ab
adam 7058ae9281 Changes 2.12.3:
* libgnutls: Several minor bugfixes.
* libgnutls: Restored HMAC-MD5 for compatibility. Although considered weak,
  several sites require it for connection. It is enabled for "NORMAL" and
  "PERFORMANCE" priority strings.
* libgnutls: depend on libdl.
* libgnutls: gnutls_transport_set_global_errno() was deprecated. Use your
  system's errno fascility or gnutls_transport_set_errno().
* gnutls-cli: Correction with usage of select to check for pending data in
  gnutls sessions. It now uses gnutls_record_check_pending().
* tests: More fixes and updates for win32. Patches by LRN.
* libgnutls: Several files unnecessarily included <gcrypt.h>; this has been
  fixed.
** API and ABI modifications: gnutls_transport_set_global_errno: DEPRECATED

Changes 2.12.2:
* libgnutls: Several updates and fixes for win32. Patches by LRN.
* libgnutls: Several bug and memory leak fixes.
* srptool: Accepts the -d option to enable debugging.
* libgnutls: Corrected bug in gnutls_srp_verifier() that prevented the
  allocation of a verifier. Reported by Andrew Wiseman.

Changes 2.12.1:
* certtool: Generated certificate request with stricter permissions.
* libgnutls: Bug fixes in opencdk code. Reported by Vitaly Kruglikov.
* libgnutls: Corrected windows system_errno() function prototype.
* libgnutls: C++ compatibility fix for compat.h. Reported by Mark Brand.
* libgnutls: Fix size of gnutls_openpgp_keyid_t by using the
  GNUTLS_OPENPGP_KEYID_SIZE definition. Reported by Andreas Metzler.
2011-04-26 10:35:29 +00:00

22 lines
1,023 B
Text

$NetBSD: patch-ab,v 1.13 2011/04/26 10:35:30 adam Exp $
--- doc/Makefile.in.orig 2011-04-22 11:41:08.000000000 +0000
+++ doc/Makefile.in
@@ -942,7 +942,7 @@ top_srcdir = @top_srcdir@
EXTRA_DIST = TODO certtool.cfg gnutls.ps gnutls.pdf gnutls.html \
doxygen/Doxyfile.in doxygen/Doxyfile.orig texinfo.css \
$(guile_texi) extract-guile-c-doc.scm
-SUBDIRS = examples cyclo scripts manpages credentials $(am__append_1)
+SUBDIRS = cyclo scripts manpages credentials $(am__append_1)
info_TEXINFOS = gnutls.texi
# Examples.
@@ -1170,7 +1170,7 @@ gnutls.dvi: gnutls.texi $(srcdir)/versio
gnutls.pdf: gnutls.texi $(srcdir)/version.texi $(gnutls_TEXINFOS)
gnutls.html: gnutls.texi $(srcdir)/version.texi $(gnutls_TEXINFOS)
$(srcdir)/version.texi: $(srcdir)/stamp-vti
-$(srcdir)/stamp-vti: gnutls.texi $(top_srcdir)/configure
+$(srcdir)/stamp-vti: gnutls.texi
@(dir=.; test -f ./gnutls.texi || dir=$(srcdir); \
set `$(SHELL) $(top_srcdir)/build-aux/mdate-sh $$dir/gnutls.texi`; \
echo "@set UPDATED $$1 $$2 $$3"; \