pkgsrc/lang/ghc7/patches/patch-mk_config.mk.in
jperkin e9e7650572 Apply a number of fixes:
* Install the libffi libtool archive.  Whilst it is unused, it allows
    us to automatically determine the shared library suffix.

  * Switch the i386 SunOS bootstrap to .xz.

  * Use PKG_CC to build lndir to help environments where the compiler is
    not in $PATH.

  * Apply patch from Alain O'Dea to fix issues with files residing on
    read-only file systems.

  * Support shared libraries on 64-bit SunOS.

  * Fix typo in patches/patch-rts_Linker.c.

Fixes build on SunOS.  Bump PKGREVISION.
2014-05-21 16:07:59 +00:00

14 lines
452 B
Makefile

$NetBSD: patch-mk_config.mk.in,v 1.1 2014/05/21 16:07:59 jperkin Exp $
Support shared libraries on 64-bit SunOS.
--- mk/config.mk.in.orig 2013-04-18 21:22:46.000000000 +0000
+++ mk/config.mk.in
@@ -124,6 +124,7 @@ SharedLibsPlatformList =
ifeq "$(SOLARIS_BROKEN_SHLD)" "NO"
SharedLibsPlatformList += i386-unknown-solaris2
+SharedLibsPlatformList += x86_64-unknown-solaris2
endif
PlatformSupportsSharedLibs = $(if $(filter $(TARGETPLATFORM),\