d62c883615
Lots of changes, notably now it uses Linux-2.6.11.x, a NetBSD bug was fixed. pkgsrc changes: * Honor PKG_SYSCONFDIR and SUPPORT_FILES for configuration files. * xend.sh: no more python warning messages when the script is used on non NetBSD/Xen systems.
21 lines
872 B
Text
21 lines
872 B
Text
$NetBSD: patch-aj,v 1.2 2005/05/24 16:02:08 xtraeme Exp $
|
|
|
|
--- libxutil/Makefile.orig 2005-05-24 00:36:28.000000000 +0000
|
|
+++ libxutil/Makefile 2005-05-24 00:38:14.000000000 +0000
|
|
@@ -65,11 +65,11 @@
|
|
fi
|
|
|
|
install: build
|
|
- [ -d $(DESTDIR)/usr/lib ] || $(INSTALL_DIR) -p $(DESTDIR)/usr/lib
|
|
- $(INSTALL_PROG) libxutil.so.$(MAJOR).$(MINOR) $(DESTDIR)/usr/lib
|
|
- $(INSTALL_DATA) libxutil.a $(DESTDIR)/usr/lib
|
|
- ln -sf libxutil.so.$(MAJOR).$(MINOR) $(DESTDIR)/usr/lib/libxutil.so.$(MAJOR)
|
|
- ln -sf libxutil.so.$(MAJOR) $(DESTDIR)/usr/lib/libxutil.so
|
|
+ $(BSD_INSTALL_LIB_DIR) $(PREFIX)/lib
|
|
+ $(BSD_INSTALL_LIB) libxutil.so.$(MAJOR).$(MINOR) $(PREFIX)/lib
|
|
+ $(BSD_INSTALL_LIB) libxutil.a $(PREFIX)/lib
|
|
+ ln -sf libxutil.so.$(MAJOR).$(MINOR) $(PREFIX)/lib/libxutil.so.$(MAJOR)
|
|
+ ln -sf libxutil.so.$(MAJOR) $(PREFIX)/lib/libxutil.so
|
|
|
|
clean:
|
|
$(RM) *.a *.so* *.o *.opic *.rpm
|