pkgsrc/lang/a60/patches/patch-aa
mef db5bdfd6c0 (pkgsrc)
- Update MASTER_SITES and HOMEPAGE
 - patches/patch-bltin.h  added to #include <time.h>
(upstream)
 - Update 0.20a to 0.23a
   ---------------------
Mon Jul 28 20:10:34 CEST 2014  Erik Schoenfelder  <schoenfr@web.de>

	* version increased to 0.23a

	* configure.in, Makefile.in: modified to work with newer autoconf
	version and creation of documentation. moved to more appropriate
	zip instead of old zoo format (oh yeah, those old dayes...).

	* a60-mkc.inc, a60.texinfo, test/*: add FILE_n input / output
	handling allowing channels 2 to 15 mapped to files.

Thu Jul 10 21:19:45 CEST 2014  Erik Schoenfelder  <schoenfr@web.de>

	* <many-files> change old e-mail addresses
	  schoenfr@ibr.cs.tu-bs.de and schoenfr@gaertner.de to a more
	  appropriate schoenfr@web.de address.

	* bltin.c, a60-mkc.inc, a60.texinfo: add builtin function
	  intinteger().

	* test/input.a60: add ininteger() test.

Thu Apr 21 00:42:11 MEST 2005  Erik Schoenfelder  <schoenfr@web.de>

	* a60.texinfo: fixed typo where write incorrectly state it
  	  would return an integer value.

	  Again, thanks to "Warren R. Carithers" <wrc@cs.rit.edu> for
	  pointing this out.

Wed Apr 13 18:49:44 MEST 2005  Erik Schoenfelder  <schoenfr@web.de>

	* insymbol(): the index now starts with 0, so the index
	  correspondents to outsymbol.

	* a60.texinfo: fixed typo where insymbol incorrectly state it
	  would return an integer value.

	* test/runtest.sh: addes test case input.a60

        * Thanks to "Warren R. Carithers" <wrc@cs.rit.edu> for
	  pointing this out.
2015-02-21 13:07:02 +00:00

42 lines
892 B
Text

$NetBSD: patch-aa,v 1.4 2015/02/21 13:07:02 mef Exp $
Configure for pkgsrc.
Honor CPPFLAGS and LDFLAGS via autoconf.
--- Makefile.in.orig 2014-07-29 00:27:10.000000000 +0900
+++ Makefile.in 2015-02-21 21:53:23.000000000 +0900
@@ -34,7 +34,7 @@
exec_prefix = @exec_prefix@
BINDIR = $(exec_prefix)/bin
-LIBDIR = $(prefix)/lib
+LIBDIR = $(prefix)/share/a60
MANDIR = $(prefix)/man/man1
MANSUFF = 1
@@ -66,13 +66,15 @@
DEFS = -DHAVE_CONFIG_H
##
+CPPFLAGS= @CPPFLAGS@
+
##
## Flags for debugging and production:
##
# FLAGS = -g
FLAGS = -g -O -DDEBUG
# LDFLAGS = -g
-LDFLAGS =
+LDFLAGS = @LDFLAGS@
## Uncomment for profiling:
# PROF = -pg
@@ -149,7 +151,7 @@
SRCS = $(ISRCS) $(MSRCS)
HDRS = $(IHDRS) $(MHDRS)
-CFLAGS = $(FLAGS) $(PROF) $(WARN) $(DEFS) $(LIBDIRPATH)
+CFLAGS += $(PROF) $(WARN) $(DEFS) $(LIBDIRPATH)
XCFLAGS = $(FLAGS) $(PROF) $(DEFS) $(LIBDIRPATH)
##