pkgsrc/devel/cmake/patches/patch-ac
adam cf5859bc54 Changes 2.8.3:
* When processing DartMeasurements use the tests working directory.
* ExternalProject: No svn --username if empty.
* Avoid problem reading jni.h on Macs.
* Fixed appending PATH to dumpbin tool from growing without bounds.
* Switch to CMAKE_PATH when doing PATH comparisons on Windows.
* Remove unecessary TO_CMAKE_PATH for gp_cmd_dir.
* Append the gp_tool path to the system PATH using native slashes.
* Fixes to GetPrerequisites for cygwin.
* CPackDeb Added several optional debian binary package fields.
* ENH: Added case for Python 2.7.
* Fixed parallel build for generators with EXTRA.
2010-11-11 08:34:01 +00:00

20 lines
754 B
Text

$NetBSD: patch-ac,v 1.5 2010/11/11 08:34:02 adam Exp $
--- Modules/FindPythonLibs.cmake.orig 2010-11-10 20:06:34.000000000 +0000
+++ Modules/FindPythonLibs.cmake
@@ -27,7 +27,14 @@ INCLUDE(CMakeFindFrameworks)
# Search for the python framework on Apple.
CMAKE_FIND_FRAMEWORKS(Python)
-FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+# for pkgsrc: force Python version (set in pyversion.mk)
+IF(DEFINED PYVERSSUFFIX)
+ SET(_VERSIONS ${PYVERSSUFFIX})
+ELSE(DEFINED PYVERSSUFFIX)
+ SET(_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+ENDIF(DEFINED PYVERSSUFFIX)
+
+FOREACH(_CURRENT_VERSION ${_VERSIONS})
STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
IF(WIN32)
FIND_LIBRARY(PYTHON_DEBUG_LIBRARY