0.17.3 ====== * Updated MAINTAINERS * Dropped rep.m4 - use librep.pc instead * Improved librep.pc * Updated librep.spec * Add -L/lib$libsuff to READLINE_LIBS [T2 Patch] * Fix compilation on PPC64 [Marcus Comstedt] * Small fixup in src/fake-libexec [SuSE] * No rpath in src/rep-config.sh [Fedora] * Added ebuild [Harald van Dijk] * Improved Makefile's distclean rule * Reworked autogen.sh * Reworked configure.in * Major rework of the spec-file * Improved configure's ending message * Fixed configure.in's templates for autoheader * BSD-Tar is not supported by librep, give users a usefull warning message [Mark Diekhans] 0.17.2 ====== * fixups for configure.in * updated BUGS, HACKING and README * define inline if undefined (fixes compiler warnings) * create the destination directory for the .pc file before installing it * fixed in issue with FreeBSD in numbers.c [FreeBSD patch] * improved a function of numbers.c [FreeBSD patch] * rep_file_fdopen has not been listed in librep.sym * added -tag=CC to libtool in several places * don't ignore $LDFLAGS upon build * dropped some useless code in sdbm.c * make sure inline is defined 0.17.1 ====== * started code-cleanup * added a .pc file * added -no-split to makeinfo [FreeBSD patch] * added -enable-paranoia to configure [compile with CFLAGS+="-Wall -ansi"] * updated the spec file * replaced a static void by a void in main.c [Debian patch] * use correct shebang in rep-xgettext.jl [ALT-Linux patch] * trim trailing / to mkdir(2) [NetBSD patch]
25 lines
739 B
Text
25 lines
739 B
Text
$NetBSD: patch-aa,v 1.10 2009/04/16 18:08:32 tnn Exp $
|
|
|
|
--- configure.orig 2009-04-16 19:45:18.000000000 +0200
|
|
+++ configure
|
|
@@ -21553,17 +21553,17 @@ fi
|
|
|
|
mv librep.ebuild librep-$version.ebuild
|
|
|
|
-if test "$with_gmp" != "no" && test "$found_gmp" == "yes" ; then
|
|
+if test "$with_gmp" != "no" && test "$found_gmp" = "yes" ; then
|
|
with_gmp=yes
|
|
else with_gmp=no
|
|
fi
|
|
|
|
-if test "$with_readline" != "no" && test "$found_readline" == "yes"; then
|
|
+if test "$with_readline" != "no" && test "$found_readline" = "yes"; then
|
|
with_readline=yes
|
|
else with_readline=no
|
|
fi
|
|
|
|
-if test "$with_libffi" != "no" && test "$found_ffi" == "yes"; then
|
|
+if test "$with_libffi" != "no" && test "$found_ffi" = "yes"; then
|
|
with_ffi=yes
|
|
else with_ffi=no
|
|
fi
|