pkgsrc/games/quakeforge/patches/patch-ad
snj 6d8afaf59c Update to quakeforge 0.5.5.
This release fixes zillions of bugs (most notably, game saving/loading
now works).  Also included is PNG support.  There are too many little
changes to note, so see the ChangeLog for details.
2004-08-25 20:26:17 +00:00

22 lines
1.2 KiB
Text

$NetBSD: patch-ad,v 1.2 2004/08/25 20:26:18 snj Exp $
--- ruamoko/cl_menu/Makefile.in.orig 2004-05-02 13:52:34.000000000 -0700
+++ ruamoko/cl_menu/Makefile.in 2004-08-24 15:22:17.000000000 -0700
@@ -361,7 +361,7 @@ QFCC_DEP = $(top_builddir)/tools/qfcc/so
QFCC = $(QFCC_DEP)
QCFLAGS = -qq -g -Werror
QCPPFLAGS = -I. -I$(srcdir) -I$(top_builddir)/ruamoko/include -I$(top_srcdir)/ruamoko/include -I$(top_builddir)/include -I$(top_srcdir)/include
-GZIP = if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
+XGZIP = if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
@HAVE_ZLIB_FALSE@GZ =
@HAVE_ZLIB_TRUE@GZ = .gz
menu_data = menu.dat$(GZ)
@@ -571,7 +571,7 @@ uninstall-am: uninstall-info-am uninstal
menu.dat$(GZ): $(menu_obj) $(QFCC_DEP) ../lib/libcsqc.a ../lib/libr.a ../gui/libgui.a
$(QFCC) $(QCFLAGS) -p $(STRIP) -o menu.dat $(menu_obj) ../gui/libgui.a ../lib/libcsqc.a ../lib/libr.a
- $(GZIP)
+ $(XGZIP)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: