f6b00a9e48
* Major code cleanup. * "User unknown" reports complete local address, including extensions. * Only run courierfilters after all control files are closed. * "opt BOFHHEADERLIMIT" replaces hardcoded limit of 100,000 bytes of headers per message. * Reject <@domain.com> for a recipient's address. * Tolerate newline-less responses from the filter. * Document that sysexit 100 from .courier is a permanent failure. * "courier show all" and "courier clear all" commands for managing backscatter suppression list.
109 lines
3.2 KiB
Text
109 lines
3.2 KiB
Text
$NetBSD: patch-ac,v 1.4 2007/10/15 15:37:14 jlam Exp $
|
|
|
|
--- courier/doc/Makefile.in.orig Sun Jul 22 01:32:34 2007
|
|
+++ courier/doc/Makefile.in
|
|
@@ -151,7 +151,7 @@ top_srcdir = @top_srcdir@
|
|
version = @version@
|
|
htmldocdir = @datadir@/htmldoc
|
|
CLEANFILES = permissions.dat
|
|
-miscfiles = japanese_flag.png chinese_flag.png bg.gif icon.gif manpage.css \
|
|
+miscfiles = japanese_flag.png chinese_flag.png bg.gif icon.gif \
|
|
draft-varshavchik-exdata-smtpext.txt \
|
|
draft-varshavchik-verp-smtpext.txt \
|
|
draft-varshavchik-security-smtpext.txt \
|
|
@@ -189,66 +189,39 @@ htmlin = \
|
|
courier.html \
|
|
courierldapaliasd.html \
|
|
couriermlm.html \
|
|
- courierpop3d.html \
|
|
- couriertcpd.html \
|
|
- couriertls.html \
|
|
- deliverquota.html \
|
|
dot-courier.html \
|
|
dot-forward.html \
|
|
esmtpd.html \
|
|
- imapd.html \
|
|
localmailfilter.html \
|
|
- lockmail.html \
|
|
- mailbot.html \
|
|
- maildiracl.html \
|
|
- maildir.html \
|
|
- maildirkw.html \
|
|
- maildirmake.html \
|
|
- maildirquota.html \
|
|
- maildropex.html \
|
|
- maildropfilter.html \
|
|
- maildropgdbm.html \
|
|
- maildrop.html \
|
|
- maildrop.README.html \
|
|
- maildroptips.html \
|
|
mailq.html \
|
|
makeacceptmailfor.html \
|
|
makealiases.html \
|
|
- makedat.html \
|
|
makehosteddomains.html \
|
|
- makemime.html \
|
|
makepercentrelay.html \
|
|
makesmtpaccess.html \
|
|
- mimegpg.html \
|
|
mkesmtpdcert.html \
|
|
- mkimapdcert.html \
|
|
- mkpop3dcert.html \
|
|
- pcp_README.html \
|
|
pop3d.html \
|
|
preline.html \
|
|
- reformail.html \
|
|
- reformime.html \
|
|
sendmail.html \
|
|
submit.html \
|
|
testmxlookup.html \
|
|
webmlmd.html
|
|
|
|
htmldoc_DATA = $(nohtmlin) $(htmlin)
|
|
-man1 = sendmail.1 preline.1 maildirmake.1 cancelmsg.1 lockmail.1 maildrop.1 \
|
|
- mailq.1 mailbot.1 makemime.1 mimegpg.1 maildiracl.1 \
|
|
- makedat.1 reformail.1 reformime.1 couriermlm.1 testmxlookup.1 \
|
|
- dot-forward.1 couriertls.1 couriertcpd.1 maildirkw.1 webmlmd.1
|
|
-
|
|
-man5 = dot-courier.5 maildir.5
|
|
-man7 = localmailfilter.7 maildirquota.7 maildropgdbm.7 maildropfilter.7 \
|
|
- maildropex.7
|
|
+man1 = sendmail.1 preline.1 cancelmsg.1 \
|
|
+ mailq.1 \
|
|
+ couriermlm.1 testmxlookup.1 \
|
|
+ dot-forward.1 webmlmd.1
|
|
|
|
-man8 = aliaslookup.8 courier.8 courierldapaliasd.8 courierpop3d.8 \
|
|
+man5 = dot-courier.5
|
|
+man7 = localmailfilter.7
|
|
+
|
|
+man8 = aliaslookup.8 courier.8 courierldapaliasd.8 \
|
|
deliverquota.8 \
|
|
esmtpd.8 makeacceptmailfor.8 makehosteddomains.8\
|
|
- mkesmtpdcert.8 mkimapdcert.8 mkpop3dcert.8 \
|
|
+ mkesmtpdcert.8 \
|
|
makealiases.8 makepercentrelay.8 makesmtpaccess.8 \
|
|
- pop3d.8 submit.8 imapd.8
|
|
+ submit.8
|
|
|
|
BUILT_SOURCES = \
|
|
aliaslookup.html aliaslookup.8 \
|
|
@@ -275,7 +248,7 @@ BUILT_SOURCES = \
|
|
webmlmd.html.in webmlmd.1.in
|
|
|
|
EXTRA_DIST = $(nohtmlin) $(BUILT_SOURCES)
|
|
-man_LINKS = $(man8dir)/courierpop3login.8 \
|
|
+man_LINKS = \
|
|
$(man1dir)/rmail.1 $(man1dir)/dotforward.1 \
|
|
$(man8dir)/makesmtpaccess-msa.8 \
|
|
$(man8dir)/esmtpd-msa.8
|
|
@@ -1156,8 +1129,7 @@ preline.1: preline.1.in
|
|
|
|
install-man-extra:
|
|
cd $(DESTDIR)$(man8dir) ; \
|
|
- rm -f courierpop3login.8 makesmtpaccess-msa.8 esmtpd-msa.8; \
|
|
- $(LN_S) courierpop3d.8 courierpop3login.8; \
|
|
+ rm -f makesmtpaccess-msa.8 esmtpd-msa.8; \
|
|
$(LN_S) makesmtpaccess.8 makesmtpaccess-msa.8 ; \
|
|
$(LN_S) esmtpd.8 esmtpd-msa.8
|
|
cd $(DESTDIR)$(man1dir) ; rm -f rmail.1 dotforward.1 \
|