pkgsrc/multimedia/libdv/patches/patch-ac
jmmv fbc1e6ed01 Split libdv into two packages: libdv itself, which installs only the codec
library, and libdv-tools, which installs all the associated tools.
While doing this, clean-up useless dependencies in libdv's buildlink3.mk
file.

The main purpose of this change is to let mplayer use the dv codec (which
is the default setting) while not depending on unused packages (gtk+).
2005-06-03 15:40:30 +00:00

22 lines
926 B
Text

$NetBSD: patch-ac,v 1.1 2005/06/03 15:40:31 jmmv Exp $
--- playdv/Makefile.in.orig 2004-11-30 03:23:43.000000000 +0000
+++ playdv/Makefile.in
@@ -58,7 +58,7 @@ am_playdv_OBJECTS = playdv.$(OBJEXT) dis
playdv_OBJECTS = $(am_playdv_OBJECTS)
am__DEPENDENCIES_1 =
playdv_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) ../libdv/libdv.la $(am__DEPENDENCIES_1)
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@@ -209,7 +209,7 @@ CLEANFILES =
AM_CFLAGS = $(SDL_CFLAGS) $(GTK_CFLAGS)
noinst_HEADERS = display.h oss.h
playdv_SOURCES = playdv.c display.c display.h oss.c
-playdv_LDADD = $(SDL_LIBS) $(GTK_LIBS) $(XV_LIB) ../libdv/libdv.la $(POPT_LIB)
+playdv_LDADD = $(SDL_LIBS) $(GTK_LIBS) $(XV_LIB) `pkg-config --libs libdv` $(POPT_LIB)
all: all-am
.SUFFIXES: