pkgsrc/games/pytraffic/patches/patch-aa

24 lines
966 B
Text

$NetBSD: patch-aa,v 1.1.1.1 2005/07/20 19:46:27 drochner Exp $
--- setup.py.orig 2005-07-19 18:29:58.000000000 +0200
+++ setup.py
@@ -48,7 +48,7 @@ except ImportError:
# Furthermore both their location and content depend on <prefix>.
# Distutils should really have a 'configure' step.
if os.name=='posix':
- prefix='/usr/local'
+ prefix=os.environ['PREFIX']
for arg_index in xrange(1,len(sys.argv)):
arg=sys.argv[arg_index]
if arg=='--prefix':
@@ -84,8 +84,8 @@ if py2exe_present:
# We now construct the files pytraffic and pytraffic.desktop. We will
# remove them afterwards.
if os.name=='posix':
- main_command_contents=r"""exec python %s/share/%s/Game.py
-""" % (prefix,version.install_leaf)
+ main_command_contents=r"""exec %s %s/share/%s/Game.py
+""" % (sys.executable,prefix,version.install_leaf)
main_command_file=open("pytraffic","w")
main_command_file.write(main_command_contents)