pkgsrc/devel/cmake/patches/patch-ac
adam cdc27971b3 Changes 3.1.0:
* Windows Phone and Windows Store support has been added to  Visual Studio 11
  (2012) and above Generators.
* NVIDIA Nsight Tegra support has been added to  Visual Studio 10 (2010) and
  above Generators.
* New "target_compile_features" command allows populating target based compile
  features. CMake uses this information to ensure that the compiler in use is
  capable of building the target, and to add any necessary compile flags
  such as -std=gnu++11 to support language features.
  More information on this is found at:
  - http://www.cmake.org/cmake/help/v3.1/manual/cmake-compile-features.7.html
* The syntax for *Variable References* and *Escape Sequences* was simplified in
  order to allow a much faster implementation. See policy "CMP0053".
* The "if" command no longer automatically dereferences variables named in
  quoted or bracket arguments.  See policy "CMP0054".
* The target property "SOURCES" now generally supports "Generator Expressions".
  The generator expressions may be used in the "add_library" and
  "add_executable" commands.
* It is now possible to write and append to the target property "SOURCES".
  The variable "CMAKE_DEBUG_TARGET_PROPERTIES" can be used to trace the
  origin of sources.
* CPack gained "7Z" and "TXZ" generators supporting lzma-compressed archives.
* The ExternalProject module has learned to support lzma-compressed
  source tarballs with ".7z", ".tar.xz", and ".txz" extensions.
* The ExternalProject module ExternalProject_Add command learned a new
  BUILD_ALWAYS option to cause the external project build step to run every
  time the host project is built.
* The ctest_coverage command learned to support Intel coverage files with the
  "codecov" tool.
* The ctest_memcheck command learned to support sanitizer modes, including
  "AddressSanitizer", "MemorySanitizer", "ThreadSanitizer", and
  "UndefinedBehaviorSanitizer".
2015-01-17 13:29:55 +00:00

29 lines
1.1 KiB
Text

$NetBSD: patch-ac,v 1.11 2015/01/17 13:29:55 adam Exp $
Insist on select python version for pkgsrc.
--- Modules/FindPythonLibs.cmake.orig 2014-12-15 20:07:43.000000000 +0000
+++ Modules/FindPythonLibs.cmake
@@ -82,6 +82,13 @@ else()
set(_PYTHON_FIND_OTHER_VERSIONS ${_PYTHON3_VERSIONS} ${_PYTHON2_VERSIONS} ${_PYTHON1_VERSIONS})
endif()
+# for pkgsrc: force Python version (set in pyversion.mk)
+if(DEFINED PYVERSSUFFIX)
+ set(_VERSIONS ${PYVERSSUFFIX})
+else()
+ set(_VERSIONS ${_PYTHON2_VERSIONS} ${_PYTHON3_VERSIONS})
+endif()
+
# Set up the versions we know about, in the order we will search. Always add
# the user supplied additional versions to the front.
# If FindPythonInterp has already found the major and minor version,
@@ -91,7 +98,7 @@ set(_Python_VERSIONS ${Python_ADDITIONAL
if(DEFINED PYTHON_VERSION_MAJOR AND DEFINED PYTHON_VERSION_MINOR)
list(APPEND _Python_VERSIONS ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
endif()
-list(APPEND _Python_VERSIONS ${_PYTHON_FIND_OTHER_VERSIONS})
+list(APPEND _Python_VERSIONS ${_VERSIONS})
unset(_PYTHON_FIND_OTHER_VERSIONS)
unset(_PYTHON1_VERSIONS)