pkgsrc/security/mixminion/patches/patch-ab
wiz 68ea71aa3e Initial import of mixminion-0.0.7.1, provided by Peter Hendrickson
in PR 25573, with some cleanup by me.

Mixminion is a communication security application for electronic mail
messages.  Its purpose is to deny an adversary the ability to
determine who is communicating with whom and to provide the closely
related service of anonymous communication.

It does this by sending messages through a series of servers.
Messages going into and out of each server are encrypted.  Each server
keeps a pool of messages.  When a message comes in it is placed in the
pool.  Messages sent out from the pool are difficult to correlate with
the messages going in.  This process is called "mixing."

Each server reduces the ability of the adversary to determine the
origin of a message.  Chaining the servers further reduces this
ability and contains the damage caused by compromised servers.  The
chain of servers is chosen by the Mixminion software running on the
user's machine.

See http://mixminion.net for a complete description.
2004-12-27 22:58:57 +00:00

52 lines
1.6 KiB
Text

$NetBSD: patch-ab,v 1.1.1.1 2004/12/27 22:58:57 wiz Exp $
--- setup.py.orig 2004-05-10 19:36:22.000000000 +0200
+++ setup.py
@@ -492,6 +492,9 @@ if os.path.exists("/usr/kerberos/include
INCLUDE_DIRS.append("src")
+INCLUDE_DIRS.append('/usr/pkg/include')
+INCLUDE_DIRS.append('/usr/include')
+
EXTRA_CFLAGS = []
if sys.platform != 'win32':
EXTRA_CFLAGS += [ '-Wno-strict-prototypes' ]
@@ -534,6 +537,28 @@ elif sys.platform != 'win32':
else:
EXTRA = {}
+EXTRA = {'data_files':
+ [('man/man1', ['etc/mixminion.1']),
+ ('man/man5', ['etc/mixminionrc.5', 'etc/mixminiond.conf.5']),
+ ('man/man8', ['etc/mixminiond.8'])]}
+
+orig_opts = sysconfig.get_config_vars('OPT')
+if orig_opts == ['-DNDEBUG -O2 -I/usr/pkg/include -I/usr/include']:
+ sysconfig._config_vars['OPT'] = '-DNDEBUG -O2'
+elif orig_opts == ['-DNDEBUG -O2 -I/usr/include']:
+ sysconfig._config_vars['OPT'] = '-DNDEBUG -O2'
+elif orig_opts == ['-O2 -I/usr/include']:
+ sysconfig._config_vars['OPT'] = '-O2'
+elif orig_opts == ['-DNDEBUG -g -O3 -Wall -Wstrict-prototypes']:
+ pass
+elif orig_opts == ['-g -O2 -Wall -Wstrict-prototypes']:
+ pass
+else:
+ # The package defines the Python packages it can rely upon.
+ # If we get here, this assumption is invalid.
+ print "Looks like the Python we are using has unexpected properties."
+ sys.exit(1)
+
setup(name='Mixminion',
version=VERSION,
license="LGPL",
@@ -550,6 +575,8 @@ setup(name='Mixminion',
**EXTRA
)
+sysconfig._config_vars['OPT'] = orig_opts
+
try:
for s in SCRIPTS:
os.unlink(s)