b4c00c20bf
pancake <pancake at phreaker dot org>. xml2doc is an xml files processor tool, that allows you to write documents in a simple XML way and then output then in various formats (pdf,html,txt,manpage,...). In first term is intended to be a lightweight version of DocBook, but smaller (20KB against 100MB), faster, easy to learn, and very flexible.
27 lines
1 KiB
Text
27 lines
1 KiB
Text
$NetBSD: patch-aa,v 1.1.1.1 2004/02/23 08:39:00 xtraeme Exp $
|
|
|
|
--- doc/Makefile.in.orig 2004-02-23 09:26:44.000000000 +0100
|
|
+++ doc/Makefile.in 2004-02-23 09:31:00.000000000 +0100
|
|
@@ -9,7 +9,6 @@
|
|
export PATH=$(PATH):$(PWD)/src/ ;
|
|
for A in *.xml; do xml2doc -oP $$A $$A.pdf ; done ;
|
|
xml2doc -oM manpage.xml manpage.man ;
|
|
- gzip manpage.man ;
|
|
@printf "\e[32mDONE\e[0m\n"
|
|
|
|
mrproper: clean
|
|
@@ -21,10 +20,10 @@
|
|
install: build
|
|
@printf "\e[32mInstalling documentation...\e[0m\n"
|
|
@mkdir -p $(PREFIX)/share/man/man1
|
|
- cp -f manpage.man.gz $(PREFIX)/share/man/man1/xml2doc.1.gz
|
|
- gzip -f $(PREFIX)/share/man/man1/xml2doc.1
|
|
- @mkdir -p $(PREFIX)/share/doc/xml2doc
|
|
- for A in $(DOCS); do cp -f $$A $(PREFIX)/share/doc/xml2doc/ ;done
|
|
+ $(BSD_INSTALL_MAN) manpage.man $(PREFIX)/man/man1/xml2doc.1
|
|
+ @$(BSD_INSTALL_DATA_DIR) $(PREFIX)/share/doc/xml2doc
|
|
+ for A in $(DOCS); do $(BSD_INSTALL_DATA) $$A \
|
|
+ $(PREFIX)/share/doc/xml2doc/ ;done
|
|
|
|
remove:
|
|
@printf "\e[32mDeinstalling documentation...\e[0m\n"
|