Additional changes: kde option compiles now, use standard installation method for Firefox plugin. 2008-02-21 Sandro Santilli <strk@keybit.net> Fifth alpha release of Gnash (0.8.2). Improvements since 0.8.1 release are: - Improved timeline redesign. - Action execution order fixes. - Keyboard handling improved [1]. - New classes implemented: System.capabilities (partial), SharedObject, LocalConnection. - New opcodes implemented: ActionImplements, Try/Throw. - Movieclip.beginGradientFill completes drawing API support. - MovieClip._lockroot support added. - Implement GET/POST for MovieClip.loadVariables and MovieClip.loadMovie - Textfield support improved. - Security: configurable sandbox restricts filesystem access by movies. - Better support for SWF8. - Streaming OGG-contained multimedia (e.g. vorbis/theora or vorbis/dirac), and other free formats. - OGL and Cairo renderers much improved. - Improvements of the Framebuffer GUI (hide text messages, support Linux events system, built-in touchscreen calibration, simple keyboard support, better architecture support). - SOLdumper utility for reading SOL files ('flash cookies'). - DumpShm utility finds and dumps Local Connection memory segments. - Fullscreen display possible. - Extensions for LIRC and DBus. - High quality, cross-platform psuedo-randomness using boost random. - NPAPI (Mozilla) plugin: keyboard events work, navigation and javascript from within movies. - Set and save preferences from the GUI (GTK). - Improved stability and robustness with malformed SWFs. - Many other bugfixes. 2007-08-29 Sandro Santilli <strk@keybit.net> Fourth alpha release of Gnash (0.8.1). Improvements since 0.8.0 release are: - Garbage Collector - Support for device fonts - Support for dynamic text fields - Better key handling - Support for FFMPEG SVN - Support for on-demand install of needed Gstreamer codec plugins. - Debugger off by default (improves performance and memory use) - AGG renderer by default - Support for KDE/AGG combination - Layout change : we'll now build <gui>-gnash and 'gnash' is a shell script with gui selection capabilities (-G) - More robust parser - Better support for flash player detection - Fix for 'debugLog' directive in gnashrc
14 lines
699 B
Text
14 lines
699 B
Text
$NetBSD: patch-ae,v 1.1 2008/04/27 06:44:52 wiz Exp $
|
|
|
|
--- gui/Makefile.in.orig 2008-04-25 17:05:02.000000000 +0200
|
|
+++ gui/Makefile.in
|
|
@@ -1164,8 +1164,8 @@ GUI_SRCS = gnash.cpp \
|
|
@BUILD_QTOPIA_GUI_TRUE@ $(GNASH_LIBS) $(AM_LDFLAGS) \
|
|
@BUILD_QTOPIA_GUI_TRUE@ $(am__append_14) $(am__append_17)
|
|
@BUILD_KDE_GUI_TRUE@kde_gnash_CPPFLAGS = -DGUI_KDE \
|
|
-@BUILD_KDE_GUI_TRUE@ -DGUI_CONFIG=\"KDE\" $(AM_CPPFLAGS) \
|
|
@BUILD_KDE_GUI_TRUE@ $(KDE_CFLAGS) $(QT_CFLAGS) \
|
|
+@BUILD_KDE_GUI_TRUE@ -DGUI_CONFIG=\"KDE\" $(AM_CPPFLAGS) \
|
|
@BUILD_KDE_GUI_TRUE@ $(am__append_22) $(am__append_25)
|
|
@BUILD_KDE_GUI_TRUE@kde_gnash_SOURCES = $(GUI_SRCS) gui_kde.cpp \
|
|
@BUILD_KDE_GUI_TRUE@ $(am__append_24) $(am__append_27)
|