7e4a4f7195
smaller patches are nicer than larger ones. By the way, each patch should start with a line containing an RCS Id.
21 lines
667 B
Text
21 lines
667 B
Text
$NetBSD: patch-ac,v 1.2 2007/09/20 08:30:15 rillig Exp $
|
|
|
|
--- src/Makefile.am 2006-12-19 04:40:53.000000000 +0100
|
|
+++ src/Makefile.am 2007-07-27 21:30:16.000000000 +0200
|
|
@@ -96,8 +96,15 @@
|
|
|
|
$(BUILT_HEADER): $(BUILT_SOURCE)
|
|
|
|
+if CROSS_COMPILING
|
|
+MAKESTRS= $(top_builddir)/util/xmakestrs
|
|
+else
|
|
+MAKESTRS= $(top_builddir)/util/makestrs
|
|
+endif
|
|
+
|
|
+
|
|
$(BUILT_SOURCE):
|
|
- $(top_builddir)/util/makestrs -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
|
|
+ $(MAKESTRS) -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
|
|
mkdir -p $(top_builddir)/src
|
|
mkdir -p $(top_builddir)/include/X11
|
|
cp StringDefs.h $(top_builddir)/include/X11
|