c4d1b3723e
Mozilla Firefox is a free, open-source and cross-platform web browser for Windows, Linux, MacOS X and many other operating systems. It is fast and easy to use, and offers many advantages over other web browsers, such as tabbed browsing and the ability to block pop-up windows. Firefox also offers excellent bookmark and history management, and it can be extended by developers using industry standards such as XML, CSS, JavaScript, C++, etc. Many extensions are available.
17 lines
728 B
Text
17 lines
728 B
Text
$NetBSD: patch-ao,v 1.1 2017/04/27 01:55:57 ryoon Exp $
|
|
|
|
* For devel/xulrunner*
|
|
|
|
--- toolkit/mozapps/installer/packager.mk.orig 2017-04-11 02:13:24.000000000 +0000
|
|
+++ toolkit/mozapps/installer/packager.mk
|
|
@@ -139,8 +139,8 @@ endif
|
|
(cd $(DESTDIR)$(installdir) && tar -xf -)
|
|
$(NSINSTALL) -D $(DESTDIR)$(bindir)
|
|
$(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
|
|
- ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)
|
|
-ifdef INSTALL_SDK # Here comes the hard part
|
|
+ ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)/${MOZILLA_PKG_NAME}
|
|
+ifeq ($(MOZ_APP_NAME),xulrunner)
|
|
$(NSINSTALL) -D $(DESTDIR)$(includedir)
|
|
(cd $(DIST)/include && $(TAR) $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir) && tar -xf -)
|